October 8th, 2003, 05:49
In another post I was asking about passive FTP for NetBSD install to go through my OpenBSD firewall. Unfortuanatly it did not help at all. I've tried various things to get it to work. At one point, I setup the interface in the options before starting the install, and even added 'routed -q' (Seems to help with other FTP installs). After setting up for the install, I would get to the package installation page, and of course choose FTP. I would constantly get "Watchdog Timeout" errors, and it would fail. From there, I would choose to not try again, and then head to the screen to setup a proxy to go through. I set the proxy to my FTP-proxy, and still nothing would happen.

During different times of the install process I would try to ping the host I was trying to install in. Not once could I ping it, except when first setting up the interface before starting the install config. On top of trying to ping, I would watch both the interface the host would go through to get outside, and the pflog0 deivce with tcpdump to see if it was even getting outside to the server. I can't say that I saw a single connection even to my ftp-proxy. I must note that FTP installs from FreeBSD and OpenBSD worked without any trouble, but the NetBSD install has had me stumped for awile now.

The NIC is also just fine, and in perfect working order, so that negated the thought that it was the hardware. BTW, it's a built-in Realtek 10/100 ethernet adapter in my laptop. Any ideas?

October 9th, 2003, 06:47
It's my understanding that the NetBSD FTP client will open a connection using passive mode by default and fall back to active mode if the server doesn't support the EPSV command.

To be honest, I haven't run the NetBSD installer in years, but the next time I do so, I'll try to test FTP installations. I'll also take a look and see if it's possible to grab the install sets using HTTP instead of FTP since that's usually less problematic through a firewall or a proxy.

Sorry I couldn't provide more help in this case.

October 9th, 2003, 10:08
maybe this can help?

October 9th, 2003, 10:49
Watchdog timeouts are very frustrating because it might work fine with another OS on the same machine. You can often get the same results if you swap out the NIC with another type. This appears to be a combination of things causing the timeouts so the answer might take multiple things to correct it.

PNP bios is the first thing to disable since it can cause havoc with proper resource allocation. This tends to be a greater issue with systems having a lot of devices fighting for resources like laptops or just a lot of cards installed. Multiple PCI busmastering devices can fight with each other if they are going for the same resource.

The steps to try to correct it will deal with IRQ settings in the BIOS and moving slots if your BIOS doesn't give enough options. Of course this assumes you already disabled PNP in there first. Some motherboards have certain slots/onboard devices share IRQs and some even let you change that from the BIOS. Try to get as many things to free IRQs as possible especially any busmastering devices. You may have to use resource reserving in the BIOS if it's available. All this IRQ resource stuff shouldn't normally be an issue but we are dealing with the exceptions here. :?

Another workaround is to manually set the speed and duplex on the NIC(s). If you want 100 fullduplex then set it for that and don't let it autodetect that. You may want to try this first as it seems to fix things for a lot of people that have dealt with the watchdog timeouts and it's pretty easy to check.

I doubt the FTP proxy/firewall issues are really causing your problem with this. I would probably put money on you getting the same result with an internal FTP mirror too. 8)