October 13th, 2003, 15:39
Hello. Was trying to build mozilla-firebird today on my FreeBSD 4.8 test desktop station when I ran into a problem. After I isued, 'make' in the /usr/ports/www/mozilla-firebird directory, I received the following error:

[code:1:563553f929]===> Building for ORBit-0.5.17_1
/usr/libexec/ld-elf.so.1: Shared object "libintl.so.4" not found
*** Error code 1

Stop in /usr/ports/devel/ORBit.
*** Error code 1

Stop in /usr/ports/devel/ORBit.
*** Error code 1

Stop in /usr/ports/www/mozilla-firebird.
*** Error code 1

Stop in /usr/ports/www/mozilla-firebird.

I checked out ORBit and it also complained about the "libintl.so.4."

Anyone ran into this before? I'm probably missing a specific package is my guess. Just thought i'd post this quickly to see if anyone ran into this and what the quick fix is. :)


October 13th, 2003, 15:41
normally i would prefer to have about 5 to 10 lines above what you just posted.. but going off a guess here..

force a uninstall of orbit and rebuild it from the ports...

October 13th, 2003, 15:53
Check if you have libintl.so on your system, perhaps a different version than the one installed:
locate libintl.so
find /usr -name 'libintl.so*'

Your problem looks like either a certain version on libintl.so is expected or that whatever package should have included libintl.so was not installed.

On OpenBSD, i think devel/gettext supplies libintl, don't know about FreeBSD. Perhaps look for that package and make sure it's installed correctly?

October 13th, 2003, 16:02
I think I found the problem. Did some searching and found this:


Im working on this right now. I'll let everyone know how it goes.


October 13th, 2003, 16:40
That link seems to have fixed it. firebird seems to have been built successfully.

Also, any suggestions on how to build java for web browsers? Just navigate to the correct port and:

make install


October 13th, 2003, 20:21
OK. I built mozilla-firebird out of the ports tree.

I also was working with fluxbox, trying to get my desktop all nice an pretty.
I was trying to setup mozilla-firebird, but im getting the following error when I try and run Mozillafirebird-bin:

[code:1:65aaadf386]/usr/libexec/ld-elf.so.1: Shared object "libmozjs.so" not found[/code:1:65aaadf386]

Whats odd is that "libmozjs.so" is in the same directory:


I've been googling, but havent found any answers just yet.

Anyone have any suggestions?


October 13th, 2003, 21:08
Still searching, but found this interesting:

[code:1:8c7ae845c7]# ldd MozillaFirebird-bin
libmozjs.so => not found (0x0)
libxpcom.so => not found (0x0)
libplds4.so => /usr/local/lib/libplds4.so (0x28073000)
libplc4.so => /usr/local/lib/libplc4.so (0x28099000)
libnspr4.so => /usr/local/lib/libnspr4.so (0x280c1000)
libgtk12.so.2 => /usr/X11R6/lib/libgtk12.so.2 (0x280f0000)
libgdk12.so.2 => /usr/X11R6/lib/libgdk12.so.2 (0x28218000)
libgmodule12.so.3 => /usr/local/lib/libgmodule12.so.3 (0x2824c000)
libglib12.so.3 => /usr/local/lib/libglib12.so.3 (0x2824f000)
libintl.so.5 => /usr/local/lib/libintl.so.5 (0x28271000)
libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x2827a000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x28282000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x28290000)
libm.so.2 => /usr/lib/libm.so.2 (0x2834c000)
libstdc++.so.3 => /usr/lib/libstdc++.so.3 (0x28367000)
libc_r.so.4 => /usr/lib/libc_r.so.4 (0x283ac000)
libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x28461000)
libXThrStub.so.6 => /usr/X11R6/lib/libXThrStub.so.6 (0x2853c000)

What strikes me as curious is that the first item listed is not found, and that is the one it is complaining about when I try and start firebird.

BTW, is there another way to start firebird?


October 13th, 2003, 22:00
Neither libmozjs.so nor libxpcom.so are in your library cache. Find the directory they are in and try setting LD_LIBRARY_PATH to that directory (export LD_LIBRARY_PATH=/path/to/libs) or run 'ldconfig -m /path/to/libs' then try running firebird again.

If that works, i think you need to add a ldconfig_paths variable to your /etc/rc.conf to keep it set on reboot.

October 14th, 2003, 13:14
Ahh...I was wondering if it was something like that. Thanks frisco. That seemed to have fixed the problem. I longer get the error when I run MozillaFirebird-bin, but the browser does not open up when I run it. :)

The docs for Firebird seem a bit slim. Is there more information that I can read upon to get this working?

Thanks again frisco.


October 14th, 2003, 13:36
Before I forget, I meant to mention that Firebird requires JRE-1.4.2 or higher to run.

I've been reading up on the www.freebsd.org/java page as well as scanning the ports. But I noticed that for the ports, it only supports jre-1.3.1 I believe.

Any thoughts on how to get Java up and running? D/L source and install?

Thanks guys.



October 14th, 2003, 15:42
I've been running 1.3 with firebird for a while now.

You have to go download it directly from Sun and put it in /usr/ports/distfiles. This way they get you to click the you agree to their terms. 8)

October 14th, 2003, 15:53
I'm guessing, d/l the linux binary format?

Secondly, once i've d/l it, any special 'steps' to installing it?

Before I forget, anyone read the FreeBSD book from O'Reilly? I'm thinking of grabbing it as a companion for Absolute BSD.


October 14th, 2003, 16:09
Hey strog,

I just downloaded the following file:

[code:1:c33672814f]rwxr-xr-x 1 root wheel 14150306 Oct 14 12:02 j2re-1_4_2_01-linux-i586.bin

...and put it into /usr/ports/distfiles

Just a few quick questions: Reading up on the docs, it says to cd to the directory you want it installed. I guess, where would I want to put that?

Then it says just to run ./j2re-1_4_2_01-linux-i586.bin.

Maybe just cd to /usr/local ?




October 14th, 2003, 17:06
j2re-1.3 is in ports but not 1.4 yet. jdk is up to 1.4 in ports. I just drop it in the distfiles and run the port from there.

You could try it manually if you want but that would be new territory for me with j2re1.4. :)