October 25th, 2003, 00:49
Has anyone tried this IDE from activestate. I downloaded the trial for work, since I have to use W2K there, I was looking for another editor since I see Macromedia phasing out good old Homesite in the near future, seeing how the New Dreamweaver's (MX,2004) are basically ripping out features from Homesite. This Komodo looks good and the Pro version offers a debugger and cvs. Here is the link:

This should work fine on FreeBSD right?

October 25th, 2003, 01:45
There's a good chance it'll ork under emulation.

November 5th, 2003, 22:59
I installed it, but when I go to lauch the program I get the following error:
[code:1:c3a22a407a]./Mozilla/mozilla-bin: error while loading shared libraries: cannot open shared object file: No such file or directory[/code:1:c3a22a407a]
I tried to create a symlink to the libgtk thats in the /usr/X11R6/lib dir but after that I get this error:
[code:1:c3a22a407a]./Mozilla/mozilla-bin: error while loading shared libraries: /home/rob/Komodo-2.5/./Mozilla/ ELF file OS ABI invalid[/code:1:c3a22a407a]

Any ideas?

November 6th, 2003, 08:46
Possible it doesnt have the correct ELF branding?

try using brandelf on it.. think thats the command.. cant be sure w/ out access to a bsd box..

November 8th, 2003, 21:21
that is the right command, but how do I use it with Komodo?

November 10th, 2003, 21:15
If anyone has some free time to try installing this and get it to work with FreeBSD, let me know.. That would be fantastic.!!

November 12th, 2003, 12:40
Why not try KDevelop ( or Anjunta (

November 12th, 2003, 23:32
Just because I bought the personal version to use at work and would like to use it on my bsd box as well. The ones you suggested look good too.