November 9th, 2003, 10:17
for some reason, some of my installed packages haven't been running, and are throwing an error about 'out of inodes'.

this happens when i try and start xmms in XFree86 and also upon boot, sshd and moused give the same error, though apparently moused is running as i can use my mouse in X.

i haven't changed anything in my system recently, the only thing i can think of is that the power went out the other day and the pc wasn't shutdown properly.

any help is appreciated.

November 9th, 2003, 14:12
I think what happened is your FileSystem got corrupted... inodes are numbers that refer to files/dirs, lacking inodes sounds either your FS is corrupt or you'rea ctually out of inodes :lol:

November 9th, 2003, 16:27
ok, i was googling around and when i run df -i it does say i'm out of inodes on /var...is there anyway of fixing this?

also, what would cause this? i'm not out of space on the drive, just inodes

November 9th, 2003, 18:44

November 9th, 2003, 19:16
Heres some links ive been finding.


November 9th, 2003, 20:36
df -i it does say i'm out of inodes on /var [...]
also, what would cause this? i'm not out of space on the drive, just inodes
Lots and lots and lots ... and lots of very small files. Are you running netnews on that partition? Or squid?

One fix is to remove some of the offending files. The long-term fix, assuming you aren't out of inodes due to a one-time accident, is to rebuild (newfs) the filesystem with args specifying fewer bytes per inode (-i option).

(Backup the fs!!! newfs wipes it clean.)

November 10th, 2003, 19:19
ok, trying the newfs route...so i type in:

newfs -i 2 /var

figuring that 2k should double the number of inodes at my disposal since the default is 4k. but i get the error:

newfs: /var: failed to open disk for writing

also tried it as /dev/ad0s1e and it gives the same error. i'm running it as root. i check the man page for newfs and it mentions that disklabel needs to be run first, but shouldn't it already be labelled?

November 10th, 2003, 19:52
It needs to be unmounted when you do the newfs.

November 10th, 2003, 20:20
ah. that occurred to me a few minutes after i posted last.

now i think i've found the offending files...it appears to be tons of undelivered mail messages from the system to root. they're all hanging out in /var/spool/clientmqueue. looks like they're from the cron daemon...

[code:1:32c597ca01]This is a MIME-encapsulated message



The original message was received at Mon, 3 Nov 2003 02:45:01 -0500 (EST)
from root@localhost

----- Transcript of session follows -----
root... Deferred: Connection refused by []
Warning: message still undelivered after 4 hours
Will keep trying until message is 5 days old

Content-Type: message/delivery-status

Reporting-MTA: dns; Hosehead
Arrival-Date: Mon, 3 Nov 2003 02:45:01 -0500 (EST)

Final-Recipient: RFC822; root@Hosehead
Action: delayed
Status: 4.4.1
Remote-MTA: DNS; []
Last-Attempt-Date: Tue, 4 Nov 2003 03:21:15 -0500 (EST)
Will-Retry-Until: Sat, 8 Nov 2003 02:45:01 -0500 (EST)

Content-Type: message/rfc822

Return-Path: <root>
Received: (from root@localhost)
by Hosehead (8.12.9/8.12.9/Submit) id hA37j1gO069448;
Mon, 3 Nov 2003 02:45:01 -0500 (EST)
Date: Mon, 3 Nov 2003 02:45:01 -0500 (EST)
Message-Id: <200311030745.hA37j1gO069448@Hosehead>
From: root (Cron Daemon)
To: root
Subject: Cron <root@Hosehead> root /usr/libexec/atrun
X-Cron-Env: <SHELL=/bin/sh>
X-Cron-Env: <PATH=/etc:/bin:/sbin:/usr/bin:/usr/sbin>
X-Cron-Env: <HOME=/root>
X-Cron-Env: <LOGNAME=root>
X-Cron-Env: <USER=root>

root: not found

i have no idea why it's sending this. i can take a wild stab and say it has something to do witht hat last "root:not found" statement. but what couldn't it find, atrun?

November 13th, 2003, 08:21
well, whatever teh reason, i took care of the enormous amount of junk in that folder.

I just deleted the folder :)