November 22nd, 2003, 23:29
Okay, I followed the nifty tutorial here for setting up CUPS. Now, parts of it wouldn't apply because my printer is connected directly to a stand-alone computer. Still, I've done everything I can find to do and still get this when I run through the admin pages in a browser (localhost:631/admin) as root:


I had that often under SuSE, and it was fixed by installing a newer version. What is the cause here in FreeBSD? I've plowed through several pages of CUPS junk and all I get is something unusable about configuration of an IPP network. I'm not running the printer on a network!


November 23rd, 2003, 00:41
This is really messed up!

To petie's article, add:

1. Once the package is installed, please do the following (as root):

cd /var/spool
mkdir -p cups/tmp
chown -R root:daemon cups

Seeing that message during installation of the system was a waste of time. It needs to be placed in root's e-mail, to be read as part of the initial admin tasks.

2. Create folder: /var/log/cups/ as a place to create the error logs. You'll have no idea what's wrong until you do.

3. Create folder: /usr/local/etc/cups/certs/

4. Create folder: /usr/local/etc/cups/ppd/

5. THEN start cupsd: /usr/local/etc/rc.d/cupsd.sh start

6. Run the admin tool in KDE, because it does a better job of offering detailed options. As root run kcontrol, then find "Peripherals" then "Printers" and make sure the spooler is set to CUPS (selector in the lower right-hand corner). Right-click on the space where output devices
are listed and select "Add class/printer".

7. When running through the setup utility steps, and there's no drivers offered, use the navigation tool (little folder icon) to find the ppd you downloaded per petie's tutorial: /usr/local/share/cups/model/ and select that one.

8. Now the info will all be correct, except for one thing you will have edit by hand. First, finish the whole setup process and save it. A new icon with the printer's system name (mine is "lp") will appear in the devices window.

Test print page -- mine failed.

9. Check your dmesg file to see what interface/device your printer is given by the kernel. Mine was lpt0. Open
/usr/local/etc/cups/printers.conf and see if the port matches reality; mine said ttyd0. Changed it to lpt0 in this case, saved, closed and restarted the cupsd.

It works fine when tested.

Can't use modem, so go back and remake /dev/cuaa0

I'm almost afraid to try the printer again for fear it will kill the modem again. I don't see any conflict in dmesg, but I don't really know what to look for in the first place on something like this.