December 21st, 2003, 08:57

i tried doing a release(8), but the compilation stops when it comes to the ramdisks.
next i tried to compile the ramdisks, leading to this error:
[code:1:a4e03fce24]dd if=/dev/zero of=/var/tmp/image.31205 bs=512 count=3510
3510+0 records in
3510+0 records out
1797120 bytes transferred in 0.057 secs (31471000 bytes/sec)
vnconfig -v -c svnd0 /var/tmp/image.31205
vnconfig: /dev/rsvnd0c: Device not configured
*** Error code 4

Stop in /usr/local/src/distrib/i386/ramdisk_cd (line 76 of /usr/local/src/distrib/i386/ramdisk_cd/../common/Makefile.inc).[/code:1:a4e03fce24]
now i know, that the reason for the failure is vnconfig...

i can't use it any more. in the past i could and it worked.
it still doesn't work, if i use vnconfig with other parameters.

tried it with standard kernel and custom kernel, no difference. sources are up to date (3.4-current)

if anybody is interested, here my dmesg: http://www.oenone.de/dmesg.txt

hope you can help :)

December 21st, 2003, 12:09
Are you upgrading from 3.4-release to 3.4-current?

There was a change in svnd post 3.4-release. Make sure /dev/MAKEDEV is up to date and remove, then remake your svnd devices.


December 21st, 2003, 18:49
thanks, that was the problem.

i installed from a snapshot and updated with cvsup every two weeks or so.

never tried to use vnconfig after 10.10. ;)