December 30th, 2003, 16:18
I have been trying to apply the patches to FreeBSD 5-1.
I have done the following steps:
cvsup release-supfile (this works successfully)
cd /usr/src
time make buildworld (this appears to work)
shutdown now (return for /bin/sh)
time make installworld

The last command fails right away. I cannot copy and paste in freeBSD, but the error message is very much like the lfollowing:

error "osreldate.h must not be used in the kernel, use
osreldate.h; echo "#else" >> osreldate.h;
echo \#'undef __FreeBSD_version' >> osreldate.h; echo \#'define

There are a couple of more lines, and then it says:

touch: not found
Error code 127

Stop in /usr/src/include.
Error code 1

Error code 1 is repeated several times.

I have done a lot of googling, and this problem appears to be quite common. The person is always told to check the system date. My date appears to be in sync with CMOS,and it seems to be the correct date and time. I ran < adjkerntz -i > as was suggested to one person. The error would appear to be that touch is not found, but touch is in my path, and most posts that I have seen think touch is not the problem.
I have tried this several times with the same result.

If my actual error message is wanted , it will take me awhile to respond back

Thanks for any suggestions or advice.