January 12th, 2004, 00:25
I'm a total boot when it comes to FreeBSd and a total newbie when it comes to doing anything w/ BSDs other than PF really.
I installed 5.1 on my Dell In testbedspiron 8100 laptop (pIII 1gig, 512RAM, 60 gig harddrive, 64mb ATI Radeon 7500 video card, gorgeous 1600x1200 lcd). ALl of this stuff is supported in XFree 4.2 and up as far as I know. I accpeted default on all questions and elected to install all of the packages. When it came time to configure X, I figured it would a snap since my card is supported w/ 3d acceleration in X. No dice. Can't find an acceptable monitor or even my video card. What am I missing? This is my testbed box since I'm the proud owner of a new Powerbook. Mabye I should try 4.9?

January 12th, 2004, 10:12
I'm running 5.1 on an 8100, but mine has the nVidia GeForce 2Go card. If you'd like, I can at least provide my screens section later on when I've got my laptop handy.

January 12th, 2004, 20:17
Yeah, cool man. I'll just swap that in there. Wonder why I ddin't see my video card...

January 12th, 2004, 20:39
Google found me this (searched for "XF86Config dell 8100 radeon") :

It's a tad dated but for the most part should work. Maybe.

January 13th, 2004, 13:20
It's been a while since I set it up, so I figured I'd give you the whole thing in case there's anything else of value in there:
[code:1:69ffbd0cee]Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/webfonts/"
FontPath "/usr/X11R6/lib/X11/fonts/mozilla/"
FontPath "/usr/X11R6/lib/X11/fonts/ppantsfonts/"
FontPath "/usr/X11R6/lib/X11/fonts/sharefont/"
FontPath "/usr/X11R6/lib/X11/fonts/freefont/"

Section "Module"
Load "dbe"
Load "extmod"
Load "glx"
Load "record"
Load "xtrap"
Load "speedo"
Load "type1"
Load "freetype"

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/sysmouse"

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 31.5 - 82.0
VertRefresh 40.0 - 150.0
DisplaySize 500 400

Section "Device"

### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "NoAccel" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "ShadowFB" # [<bool>]
#Option "UseFBDev" # [<bool>]
#Option "Rotate" # [<str>]
#Option "VideoKey" # <i>
#Option "FlatPanel" # [<bool>]
#Option "FPDither" # [<bool>]
#Option "CrtcNumber" # <i>
Identifier "Card0"
Driver "nvidia"
VendorName "nVidia Corporation"
#BoardName "NV11 [GeForce2 Go]"
#ChipSet "GeForce2 Go"
BusID "PCI:1:0:0"

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 1
SubSection "Display"
Depth 4
SubSection "Display"
Depth 8
SubSection "Display"
Depth 15
SubSection "Display"
Depth 16
SubSection "Display"
Depth 24
Modes "1600x1200"


February 3rd, 2004, 14:18
5.2 worked just fine. Now if I could figure out the black art of power management.....

February 3rd, 2004, 19:57
Yeah, I still haven't made the right offerings to the APM gods apparently. I tried creating the Dell suspend-to-disk partition as described on the Dell knowledge base, but when I try to suspend the machine to disk, it complains about the lack of a partition. I've given up for now, but I might regain some interest once school settles down a bit.