January 12th, 2004, 11:20
I have an OpenBSD server running on a Intel chip. I have an avocent console server connect via the 9-pin serial cable on the bac of the pc. Fo some reason I can not get access to the console. Any ideas.

January 12th, 2004, 11:23
Nevermind. I got it.

/etc/ttys has the serial tty turned off by default.

February 16th, 2004, 09:55
Ok I've been away for a little while, and a lot has happened. Anyway I purchased a small rackmount server for my new server setup at home. The plan was to slap 2 or 3 pci serial cards into it and use it to connect via serial, to all my devices; Soekris boards, Cisco router and switch, etc.
I've been working with the Avocent line of ethernet enabled console servers and wanted to build the same thing -- spending less than $400.
I got the server for $200 w/shipping and two 2 port pci serial cards cor $25. Not bad.

Anyway I set everything up and I can not get a connection using the cards. Let me explain. Connecting to the Cisco switch is fine so long as I use the on-board serial port. If I try to connect using on of the extra serial port I get nothing. Thats not so bad. The bad thing is the soekris board. I can not get any port to connect to it at any speed using a OBSD machine. Connections work fine at the default 19200 from a windows box. but nothing from my comm server, or a laptop for that matter.

Anyway I basically wanted to use a nc + tip combo to allow me to telnet into a serial port to admin my network devices.

Here is a copy of my dmesg:

OpenBSD 3.4 (GENERIC) #18: Wed Sep 17 03:34:47 MDT 2003
cpu0: Intel Pentium III (Coppermine) ("GenuineIntel" 686-class, 128KB L2 cache) 631 MHz
real mem = 65581056 (64044K)
avail mem = 54935552 (53648K)
using 826 buffers containing 3383296 bytes (3304K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(ed) BIOS, date 02/15/01, BIOS32 rev. 0 @ 0xfd880
pcibios0 at bios0: rev. 2.1 @ 0xfd880/0x780
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xfdf30/176 (9 entries)
pcibios0: PCI Interrupt Router at 000:31:0 ("Intel 82371FB PCI-ISA" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x4000!
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82810E" rev 0x03: rng active, 9Kb/sec
vga1 at pci0 dev 1 function 0 "Intel 82810E Graphics" rev 0x03: aperture at 0xf8000000, size 0x4000000
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
ppb0 at pci0 dev 30 function 0 "Intel 82801AA Hub-to-PCI" rev 0x02
pci1 at ppb0 bus 1
puc0 at pci1 dev 7 function 0 "NetMos 2S1P" rev 0x01: com, com, lpt
pccom3 at puc0 port 0 irq 11: ns16550a, 16 byte fifo
pccom4 at puc0 port 1 irq 11: ns16550a, 16 byte fifo
lpt3 at puc0 port 2: interrupting at irq 11
fxp0 at pci1 dev 8 function 0 "Intel 82557" rev 0x09: irq 9, address 00:30:05:08:17:df
inphy0 at fxp0 phy 1: i82555 10/100 media interface, rev. 4
pcib0 at pci0 dev 31 function 0 "Intel 82801AA LPC" rev 0x02
pciide0 at pci0 dev 31 function 1 "Intel 82801AA IDE" rev 0x02: DMA, channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <WDC AC28400R>
wd0: 16-sector PIO, LBA, 8063MB, 16383 cyl, 16 head, 63 sec, 16514064 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
pciide0: channel 1 ignored (disabled)
uhci0 at pci0 dev 31 function 2 "Intel 82801AA USB" rev 0x02: irq 9
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
"Intel 82801AA SMBus" rev 0x02 at pci0 dev 31 function 3 not configured
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
biomask 4200 netmask 4200 ttymask 4a82
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
uhidev0 at uhub0 port 1 configuration 1 interface 0
uhidev0: ATEN 4 Ports USB KVM A R1.31, rev 1.10/1.00, addr 2, iclass 3/1
ukbd0 at uhidev0: 8 modifier keys, 6 key codes
wskbd1 at ukbd0 mux 1
wskbd1: connecting to wsdisplay0
uhidev1 at uhub0 port 1 configuration 1 interface 1
uhidev1: ATEN 4 Ports USB KVM A R1.31, rev 1.10/1.00, addr 2, iclass 3/1
ums0 at uhidev1: 5 buttons and Z dir.
wsmouse0 at ums0 mux 0
uhidev0: at uhub0 port 1 (addr 2) disconnected
wskbd1: disconnecting from wsdisplay0
wskbd1 detached
ukbd0 detached
uhidev0 detached
uhidev1: at uhub0 port 1 (addr 2) disconnected
wsmouse0 detached
ums0 detached
uhidev1 detached

Any ideas would be greatly appreciated.

February 17th, 2004, 00:43
I have several soekris boxes here and have not had any problems connecting to them via my OpenBSD boxes? I'm using kermit not sure what you're using to connect.

Remember soekris is default 19200 which you already know but also 8-N-1 with no flow control

February 17th, 2004, 11:30
Hmm. i am using tip. I downloaded and installed kermit but I've not used that app for years. So I'll have to check the settings in tip. Serial ports in OBSD are configured automatically. right?

February 21st, 2004, 02:03
I've seen some discussions for OpenBSD and serial consoles. Seems there are some older discussions about cable pinouts. Some people used to have issues with some cable setups while others had no problem at all. I haven't seen anything very recent regarding that and I haven't had any trouble with it since I started messing with it (post 3.1 snaps and releases). I'm using the RJ45->DB9 adapters that came with Cisco switches on all my serial connections and it works great. I use minicom usually mostly because it reminds me of a terminal program I use to use back in the day of Apple ][gs and 2400 baud modems. Any of the other apps I've tried have worked fine

Have you set up the OpenBSD machine according to the FAQ? ( )

I'm guessing not if you are asking if it's automatically setting up serial ports. Create/edit /etc/boot.conf and you get the dmesg sent to the serial port. The changes in /etc/ttys get you a login. I edited my cdrom34.fs and added a /etc/boot.conf. I used that for my boot image on my CD. I can now boot to serial and run the setup. The downside is that it only boots that way now but blank CDs are cheap so I can make a couple different setup disks. 8)

December 28th, 2004, 17:46
umm...maybe i'm a newbie missing something here, but Strog's aforementioned FAQ link pertains to allowing serial logins (i.e. incoming), not outgoing logins to a Cisco switch/router/etc. Anybody else have any helpful tips on configuring serial devs?

December 28th, 2004, 17:57
Hi guys,

If you switch an OpenBSD server over to using a serial console as described in the OpenBSD FAQ, do you loose the ability to connect locally with keyboard and mouse?

December 28th, 2004, 18:06
From what I understand, no. As long as your /etc/ttys entry still enables normal console logins. If you redirect console messages to the serial port you may not see those, but you should still get the login prompt.

Please correct me if I'm wrong, but this (from the faq):

PC compatible computers are not designed to be run from a serial console, unlike some other platforms. Even those systems that support a serial console usually have it as a BIOS configuration option -- and should the configuration information get corrupted, you will find the system looking for a standard monitor and keyboard again. You generally must have some way to get a monitor and keyboard to your amd64 and i386 systems in an emergency.

seems to substantiate my assumptions above (that is, assuming you're using amd64 or i386. apologies if that's not the case).

December 29th, 2004, 06:24
Hi thesan,

I made the same assumption but I'm a little nervous incase I break my webserver. I think I'll setup a temporary machine to test with.

December 29th, 2004, 10:32
You will still get a login prompt if you hook up a monitor and keyboard. You will see the bootloader and then it will redirect the dmesg to the console but it will give you a login after getty starts. FreeBSD has options for console only or both. I always set my FreeBSD boxes to both so I get the same behavior as I get on my OpenBSD boxes.

I've used serial consoles on Sun, Alpha, SGI, m68k and x86 boxes. It's very useful on all the platforms but x86 is only limiting in the fact you can't get into the firmware/BIOS on a typical machine. There's some x86 servers that have serial consoles built-in and there's PC Weasel ( if you want that kind of functionality