January 12th, 2004, 17:46
Hash: SHA1

It is once again my great privilege and pleasure to announce the
availability of FreeBSD 5.2-RELEASE. Building upon the success of
FreeBSD 5.1, this release includes:

- Full Tier-1 support for single and multiprocessor AMD Athlon64 and
Opteron systems.
- Dynamically linked root partition for a smaller installation
and better integration with the Name Service Switch subsystem.
- New and improved driver support for IDE, SATA, and 802.11a/b/g
and significantly better integration with the ACPI power management
- Client support for the Network File System version 4 protocol.
- Experimental first-stage support for multithreaded filtering and
forwarding of IP traffic. This also provides the foundation for a
fully multi-threaded network stack in the next release of FreeBSD.
- In-box support for the latest Gnome 2.4 and KDE 3.1 desktops.

FreeBSD 5.2 also contains a number of significant stability and
improvements over FreeBSD 5.1. However, it is still considered a 'New
Technology' release and might not be suitable for all users. Those
more conservative needs may prefer to continue using FreeBSD 4.X.
Information on the various trade-offs involved, as well as some notes
future plans for both FreeBSD 4.X and 5.X, can be found in the Early
Adopter's Guide, available here:

For a complete list of new features and known problems, please see the
release notes and errata list, available here:

For more information about FreeBSD release engineering activities,
please see:

- -------------

FreeBSD 5.2-RELEASE supports the i386, pc98, alpha, sparc64, amd64, and
ia64 architectures and can be installed directly over the net using
bootable media or copied to a local NFS/FTP server. Distributions for
all architectures are available now.

Please continue to support the FreeBSD Project by purchasing media
from one of our supporting vendors. The following companies will be
offering FreeBSD 5.2 based products:

FreeBSD Mall, Inc.

Daemonnews, Inc.

If you can't afford FreeBSD on media, are impatient, or just want to
use it for evangelism purposes, then by all means download the ISO
images. We can't promise that all the mirror sites will carry the
larger ISO images, but they will at least be available from the
following sites. MD5 checksums for the release images are included at
the bottom of this message.



FreeBSD is also available via anonymous FTP from mirror sites in the
following countries: Argentina, Australia, Brazil, Bulgaria, Canada,
China, Czech Republic, Denmark, Estonia, Finland, France, Germany,
Hong Kong, Hungary, Iceland, Ireland, Japan, Korea, Lithuania,
Amylonia, the Netherlands, New Zealand, Poland, Portugal, Romania,
Russia, Saudi Arabia, South Africa, Slovak Republic, Slovenia, Spain,
Sweden, Taiwan, Thailand, Ukraine, and the United Kingdom.

Before trying the central FTP site, please check your regional
mirror(s) first by going to:

Any additional mirror sites will be labeled ftp2, ftp3 and so on.

More information about FreeBSD mirror sites can be found at:

For instructions on installing FreeBSD, please see Chapter 2 of The
FreeBSD Handbook. It provides a complete installation walk-through
for users new to FreeBSD, and can be found online at:

- ----------------

Many companies donated equipment, network access, or man-hours to
finance the release engineering activities for FreeBSD 5.2 including
The FreeBSD Mall, Compaq, Yahoo!, Sentex Communications, and

The release engineering team for 5.2-RELEASE includes:

Scott Long <> Release Engineering,
I386 and Alpha Release
Bruce A. Mah <> Release Engineering,
Robert Watson <> Release Engineering, Security
John Baldwin <> Release Engineering
Murray Stokely <> Release Engineering
Ken Smith <> Sparc64 Release Building,
Mirror Site Coordination
Marcel Moolenaar <> IA64 Release Building
David O'Brien <> AMD64 Release Building
Takahashi Yoshihiro <> PC98 Release Building
Kris Kennaway <> Package Building
Joe Marcus Clark (> Package Building
Jacques A. Vidrine <> Security Officer

CD Image Checksums
- ------------------

MD5 (5.2-RELEASE-i386-bootonly.iso) = 3adbf5641c35ce2fb4f60295a9131794
MD5 (5.2-RELEASE-i386-disc1.iso) = cc2c9f647850df2bf96a478f0cbf18b6
MD5 (5.2-RELEASE-i386-disc2.iso) = ae5e15ee38e3f4f2a05c9355fa0a1aed
MD5 (5.2-RELEASE-i386-miniinst.iso) = 40c9a789d7d8e472914f9bc1e34ea04f

MD5 (5.2-RELEASE-alpha-bootonly.iso) = 75f19aa7c24ac91af9bc21376a1d980b
MD5 (5.2-RELEASE-alpha-disc1.iso) = 727785cb6485828db5e7f6b75217ed55
MD5 (5.2-RELEASE-alpha-disc2.iso) = b83e38a9cd698051fc05915932b03b82
MD5 (5.2-RELEASE-alpha-miniinst.iso) = 87042a14d0de3979667bb9d41bd84d45

MD5 (5.2-RELEASE-sparc64-bootonly.iso) =
MD5 (5.2-RELEASE-sparc64-disc1.iso) = 2373f5bd491a15cfc8fa856fe92b75b9
MD5 (5.2-RELEASE-sparc64-disc2.iso) = 2fb598c20873f79fcf1afc112de06641
MD5 (5.2-RELEASE-sparc64-miniinst.iso) =

MD5 (5.2-RELEASE-ia64-bootonly.iso) = b8ac4103a1703df9dba00f14a7c7557c
MD5 (5.2-RELEASE-ia64-disc1.iso) = d473c7fc79f8e40b3e331300ead5b90e
MD5 (5.2-RELEASE-ia64-disc2.iso) = c2a59d77bac522e7f8dee0460423cc2a
MD5 (5.2-RELEASE-ia64-miniinst.iso) = a545b3974d18f0fd7796bff84b50825f

MD5 (5.2-RELEASE-amd64-bootonly.iso) = 4cefddd4dd3f1b67e9f78380a058de81
MD5 (5.2-RELEASE-amd64-disc1.iso) = 308af2fa0e96a394d445e8e89c1cbece
MD5 (5.2-RELEASE-amd64-disc2.iso) = b00834c97fbab12d3ea4b159134a8f63
MD5 (5.2-RELEASE-amd64-miniinst.iso) = 06f19271f985ca1acbd45fe9a6b13204

MD5 (5.2-RELEASE-pc98-disc2.iso) = b167880c4e644f16f7377b715ccbf7c6
MD5 (5.2-RELEASE-pc98-miniinst.iso) = 3b6ca2637d41e7052c028a41a1cefc6d

Version: GnuPG v1.2.3 (FreeBSD)


January 12th, 2004, 18:38

January 13th, 2004, 11:34
Has anyone tried 5.2 yet?

January 13th, 2004, 13:07
Has anyone tried 5.2 yet?
I tried it on a 2001-vintage Thinkpad (850MHz Celeron). While booting the install CD it freezes in one of two places (config'ing h/w) depending on whether I choose "normal" or any other (eg "safe") mode.

So I guess that's really a "no" to your question. :-)

January 13th, 2004, 17:17
I had the same trouble with RC2 on a Vaio FX210. I ended up just using the RC1 installer to install RC2. Guess it's time to upgrade already.

January 13th, 2004, 20:30
I played around a bit with RC-2 over the holidays and had severe problems with ports and packages not installing, some rather major projects, too (kdebase3). Could easily have been my own newbiness, but that's the only experience I have with 5.2 thus far. When the GA Tech mirror is active, I'll check back :)

January 14th, 2004, 09:58
been running -CURRENT and it seems pretty rock solid..

January 14th, 2004, 10:56
5.2 RC2 is going fine on my system. I plan on upgrading this weekend.

January 19th, 2004, 19:50
Just upgraded to 5.2, and my system is running like a dog :x . Though that's probably due to the fact that I did not include any optimization flags in my Make.conf file. So far however, everything is running fine ( albeit slow ).

January 19th, 2004, 20:09
just updated all my systems today.. and it's running like a champ... i've read around about certain things needing to be recompiled but havent had any issues with that at all..

January 22nd, 2004, 23:00
Mine is working great, got my soundcard and video card back up and running. Still having the network issue on reboot.

January 23rd, 2004, 01:28
Swinging right along in an Inspiron 8100. Having some issues with power management, but then again, it's UNIX on a laptop. Go figure.

January 28th, 2004, 19:52
Just recompiled 'world' with the opt flags and 5.2 is running just as fast as 5.1.

/me is happy :)

hugh nicks
February 4th, 2004, 14:37
I just put 5.2.1 on my system last night, and got kde up and running this morning, but is it just me, or is cvsupit gone from the ports? I was all set to run through KrUsTy!'s how-to, when i noticed it was gone. Are there any alternatives out there that are comparable to what was posted here?


February 4th, 2004, 15:03
I just put 5.2.1 on my system last night, and got kde up and running this morning, but is it just me, or is cvsupit gone from the ports? I was all set to run through KrUsTy!'s how-to, when i noticed it was gone. Are there any alternatives out there that are comparable to what was posted here?

Unfortunately cvsupit is gone... I don't know why but it was removed from the ports a while ago. So you'll have to configure your cvsup manually.

You'll need to install cvsup from ports /usr/ports/net/cvsup. If you don't have X11 installed you can use the port /usr/ports/net/cvsup-without-gui.

Then setup a config file for grabbing the ports tree. I call it /etc/cvsupfile, but you can call it anything you want.

*default base=/usr
*default prefix=/usr
*default release=cvs
*default tag=none
*default delete use-rel-suffix

*default tag=.

Think I stole that file from Elmore somewhere. Choose whatever cvsup server is best for you.

Then just issue the cvs command to get it all running. You can still put that in a shell script and cron it if you want. Here is the one I use,

[code:1:ee195f1555]/usr/local/bin/cvsup -g -L 2 -z /etc/cvsupfile[/code:1:ee195f1555]

That should get you updating the ports.

Guess I should update that how-to now that cvsupit is no longer in the ports...


February 4th, 2004, 15:05
is it just me, or is cvsupit gone from the ports?

cvsupit is broken, try using cvsup instead.

Save the following to a file (eg: /etc/supfile):

*default release=cvs tag=.
*default base=/usr
*default delete user-rel-suffix

and run `cvsup -g -L2 /etc/supfile' where /etc/supfile is the path to your file that stores the above values. To upgrade your /usr/src just replace ports-all with src-all, I have two files for this /etc/supfile(ports) and /etc/srcupfile(src).


EDIT: Seems as if krusty beat me to the punch :lol:

February 4th, 2004, 15:12
Only by about 2 minutes! :lol:

Nice to mention the src-all for those looking to setup tracking of the src tree as well.


February 4th, 2004, 15:19
Unfortunately cvsupit is gone... I don't know why but it was removed from the ports a while ago.

It was removed last May ( , as far as I can tell cvsupit is probably dead now.

hugh nicks
February 4th, 2004, 21:08
so far so good. i'm in the process of the portupgrade, and it's just finishing up with kde. thanks for everyone's help. i'll let you know how it goes.


hugh nicks
February 5th, 2004, 13:51
As of the time of this writing, I'm upgrading to kde 3.2. I had done my port upgrade last night, watched the raptor game, and ended going out with KrUsTy!, when he told me that 3.2 was updated in the ports at around 5 last night. So when I got home, I had to update kde all over again, and my box is still chuggin' away. Has anyone set it up yet, and if so, does it look as pretty as in my dreams?


February 5th, 2004, 15:30
So when I got home, I had to update kde all over again

Aint that a bitch!

From what I've seen so far it does not look all that different, I'll just wait til the binarie are avalable :).

hugh nicks
February 12th, 2004, 14:43
After many, many hours of compiling, recompiling and cursing, I gave up on methods to install kde3.2.0. Between the error messages I got during the make, to my cvsup going all wonky on me (instead of updating the ports, it either deleted them all, or made a duplicate), I needed to take a break.

So after my kitkat, I decided to try another method. I loaded up FBSD and did a post-install of gnome. Once that was running, I got my cvsup running and updated, then did a portupgrade. Once everything was good to go, I then tried to make kde from the ports. Once that was done, re-did my xinitrc, and away we went.

btw,I found gnome really sluggish to use, and the web browser took forever to load pages. kde 3.2. is really zippy on my machine, and i'm actually writing this post with firefox 0.8 (which i'm in love with!).

now to get NWN ready to go.....


February 13th, 2004, 19:09
Looks like 5.2.1 rc2 is out as of today. I haven't seen the new change log.