February 18th, 2004, 09:14
I'm using fluxbox, initially I was using xterm and I read a post that transparency was really difficulty to enable on that. So I switched to aterm. I can issue the command:

aterm -tr

and that works fine, but the fluxbox docs indicate that:

You can make your menus transparent if you are running a recent version of fluxbox (0.9.2 or above) by changing the "Menu Alpha" value in the configure menu. 255 = Opaque, 0 = Invisible (completely transparent). A value around 160 seems to satisfy most people.

I am running the most recent version of fluxbox, but I can't find the Menu Alpaha value mentioned. Is that a line I have to add to the init file or the menu file?
Feel free to let me know if you would use aterm or another terminal program. My fluxbox experience is minimal.
One last thing. Fluxbox reccomends you install artwiz-fonts. I installed and added the FontPath to XF86Config but I still get font load errors.
Thanks as always.

February 18th, 2004, 11:47
If you bring up the menu (default right click on desktop), and navigate through "Fluxbox" and then to "Configure", you should see the last item on that submenu is "menu alpha" just keep left clicking on that untill its down to 160.

February 18th, 2004, 16:39
You also need to have a background set by fbsetbg, and must have one of the transparency supporting background tools installed for use by fbsetbg. The doc area on the flubox webpage gives you a list. I use "feh" /usr/ports/graphisc/feh, and have had no problems with menu transparency in fluxbox 0.98 on FreeBSD 5.2.1

As far as the terminal application, you can use anything that you like or are comfortable with. Bother Eterm and aterm have transparency support and work great. I have used and liked both. Konsole from the KDE package has become a favourite of mine recently because of the tabs, and I use it in fluxbox just like any other app. I beleive it has transparency support as well.


February 18th, 2004, 17:28
I didn't need fbsetbg, I use bsetbg and works well.

February 18th, 2004, 18:10
I think I posted a How-To on Eterm transperancy. Might take a look.

February 18th, 2004, 18:13
Here you go.

February 18th, 2004, 23:06
Thanks all for the help. Got it going. Had to modify the themes as I'm sure everyone on the planet knows. The style (SmartSpace) was originally using xloadimage to load the background. After reading the posts I went with eterm to use the terminal set up given by kernel killer, I added the command line right into the menu, and then used esetroot to load the image. Took a little looking to find the -f switch which seems to scale the background image to my resolution.
Thanks again for the help.

February 19th, 2004, 11:09
You can also set the -s flag, with Esetroot, which will stretch the image to your screens resolution. The -f flag will only scale it to your screens width or height depending whichever has the highest value.

hugh nicks
February 20th, 2004, 02:43
i just started using fluxbox tonight, because i got sick of the bloat of the other 2 big giants, and i am madly impressed! this WM is the sickest i've ever used. and fast.....

i'm lovin' it. :D

February 20th, 2004, 10:53
sick of the bloat of the other 2 big giants

Give xfce4 ( a shot. You can find XFCE4 under /usr/ports/x11-wm/xfce4.

February 20th, 2004, 19:20
Does anyone know off hand how to modify font color in eterm. I'm assuming :shock: that there is a switch I can use inside that argument. I did a quick google search and didn't see anything.
It's almost to the point where rtfm is on par with stfg. Which would be, search the ******** google.

February 20th, 2004, 19:32
The '-f' flag

Eterm -f white --trans --borderless --scrollbar=false --buttonbar=false --geometry=120x25+0-0

"-f" being the foreground colour and "-b" being the background colour. Run showrgb for a list of available colours.

July 18th, 2005, 17:09
Good evening.

I just switched back to FreeBSD 4.5-REL a couple of days ago running Fluxbox as wm. A week ago I ran the same version of fluxbox (0.1.14) on Mandriva 10.2 LE 2005 with transparency available in my fluxmenu: Fluxbox ==> Configuration ==> Transparency and another option to tune alpha transparency for my menu and it worked flawlessly using wmsetbg.

Now, in FreeBSD and the same version of fluxbox the transparency option is no longer available and it drives me insane! I checked the Makefile but didn't find any compile option that I'd missed to mention to make. It's not the transparency itself that is my problem - I have transparent aterms - but no longer any option in my fluxbox menu! :(

What is this? please say you know what the solution is here I beheheheheeeeeeeeeg you.



July 18th, 2005, 17:44
Perhaps Madriva backported the Alpha patches? 0.1.x is really getting patched/hacked up.

I'm running fluxbox 0.9.3 (fluxbox-devel) and it's working fine. Try uninstalling fluxbox and try devel.

July 19th, 2005, 17:35
Thanks a lot! Now I'm dwelling in transparency again :cool: