February 24th, 2004, 06:26

I'd like to point out first of all that I'm a newbie, and that I WILL get this working or so help me god! :wink: I really want to conquer the dark beast that is UNIX, or I'll never be a man. Or something.

Anyway, I've got a new install of FreeBSD-5.2 that I installed exactly lynx and cvsup and the sys source-tree on. I added device pcm to GENERIC and recompiled the Kernel, then updated my ports with cvsup and installed XFree86-4.3.0 from ports. I fixed the configuration from some web-page on how to get X working on my particular laptop(Dell latitude x200) and later changed default color depth to 8 (didn't work at all at 24, google tells me that's probably because I don't have the agpgart.o module) so now it starts! Now the first problem. If you start X and it exits from alt-ctrl-backspace or an error, the next time you run startx the mouse cursor comes up temporarily and then the screen goes blank. The computer keeps going, but the screen is blank. If you switch to another tty there appears some cruft at the top of the screen, but still blank. THis doesn't go away until you reboot. Very annoying.

Sort of ignoring the first problem I went on to install kde3 from ports as well. After adding an .xinitrc to my home directory I started x. KDE started fine, asked me where I was and all that jazz, and got me as far as the desktop. Here it locks up and after a while restarts the computer. I try again and it locks up while I'm still in the setup wizard(appearantly it wasn't saved after the last time) and then restarts.

I REALLY appreciate all answers and I'll be glad to add any important info that I missed mentioning now if needed. Again, I just REALLY want to get this working, I've given up on open source OS's so many times before because I couldn't figure them out...

February 24th, 2004, 12:05
Seems as if your video hardware is not supported by XF86. I had this same problem a few months back, thankfully XF86-4.3.0 added support for i8* video chips. There several things you can try 1) Upgrade XF86 to a the latest CVS build, 2) get a new video card, or 3) Run `XFree86 -configure && cp /etc/X11/XF86Config' and pray that XF86Config produces a usable conf file.

Good luck.

February 24th, 2004, 12:32
Well, I can't get a new video card, since the machine is a laptop(and also finances wouldn't allow....)
It's got an intel i830M which several people have gotten working fine with much older Xfree versions and several linuces using the i810 driver.
As for the first point, am I mistaking in thinking that a freshly cvs'd ports install is the same thing? Please do correct any misapprehensions I may have....

February 24th, 2004, 12:48
I always use the X -configure option to create my configs. I tweak my mouse, monitor and default color depth and drop it in. It works better than any other method I've tried. A laptop could give a bit more grief but most have worked for me but I haven't done a lot of laptops with FreeBSD.

A good place to check for setting up FreeBSD on laptops is the FreeBSD Laptop Compatibility List page ( I did find someone had submitted a Dell Latitude x200 setup. You can find their info on their page ( He used FreeBSD 4.x but was using XFree86 4.3.0 so it could be helpful for you.

February 24th, 2004, 13:31
It's got an intel i830M which several people have gotten working fine with much older Xfree versions and several linuces using the i810 driver.

Try step three, that is how I got my i830* chip to work. Be sure to add your color depth, and resolution preference once you have generated your configuration file (IE: by hand, or xf86cfg -textmode).

Let us know how it goes.

February 24th, 2004, 13:49
If your video card is unsupported just use the framebuffer driver.

an XFree86 -configure should produce a workable conf file utilizing this driver, it's what the -configure flag uses by default it it can't detect you video card.

Also remember most laptops have a fixed resolution so depending on how old it is you'll need to use either 800x600 or 1024x768 or whatever resolution your monitor supports.

I know there are lots of examples here of peoples X files. Just search em out and you'll get it.

BTW: Welcome to S.E. Pleeb! :)

February 24th, 2004, 14:25
:D Thanks for all the replies!

I tried XFree86 -configure and ran that, but that worked less than my previous XF86Config, the background and mouse cursor came up, but no XTerms. Also, the problem of the screen blanking out remains. I looked at it and it's nearly what I had though, it detected the video card and gave it the i810 driver just as I have it. I can point out also that I've tried using the XF86Config taken straight from the Free X200 site that was linked in one of the above posts(first site I looked at in regards to this whole mess actually), I've used xf86configure, xf86cfg, and I've made my own from scratch, none of them working. Also I found a japanese site(linked from the aforementioned website) that had a config file fore 4.3.0 on freebsd 5.2(!) but this didn't work either!

I'm beginning to wonder if this might be because I may have glossed over something when I compiled my own kernel to add device pcm. perhaps something in GENERIC doesn't quite match my machine and needs changing? I'm really stumped by this strange behavior... Also I'd like to add that I've added Option "SWcursor" as reccomended by Free X200, which makes the mouse feel more responsive, but again, changes nothing of the problem.... Just in case it makes a big difference to someone with more experience looking at the problem :wink:

Thanks again for all help!

February 24th, 2004, 15:24
OH! I just remembered something I wanted to mention!
On Xserver startup and shutdown I get lines that read
[code:1:6e4c29711c]xauth: (argv):1: bad display name "lap:0" in "add" command[/code:1:6e4c29711c]
[code:1:6e4c29711c]xauth: (argv):1: bad display name "lap:0" in "remove" command[/code:1:6e4c29711c]
googling gives the impression that the general concensus is that this is a TCP/IP connection related something or other and that it can be ignored, but it struck me as worth mentioning, just in case...

February 24th, 2004, 15:49
Hello again!

I'm not sure what did it, but KDE works like a charm suddenly! I've at least used it for close to half an hour without a hitch! :D
I recompiled the kernel, though the only change was to remove things like PCI network cards that'll never be used with the laptop and tape-drive and scsi/raid support(excepting those needed for my firewire cdrom drive). I'm not sure if this is the source of KDE's new-found happiness, but I'm not going to debate it too much....

The screen-blank-untill-reboot-if-you-quit-X problem still lingers, but this isn't much of a bother I figure, if I sit in KDE most times anyway using the Konsole.
Thanks for all the help, and I'd still LOVE to know that the above problem with lap:0 isn't something to worry about!

February 24th, 2004, 16:23
I'm guessing it's a stale .Xauthority file. Perhaps if you remove the file that warning may go away.

PS: I hope you enjoy your stay on Freebie :)