March 21st, 2004, 23:01
Hello all,

Now I did it. I was changing the permissions for a user (maps) and I made him (me) part of wheel and operator groups. Now, all I get when kdm starts (which I put into ttys) is the maps user (root is no longer there) and the password no longer works. I tried logging in as root and maps (using both passwords that always worked) and I can not log in.

Please do not tell me I have to reinstall FreeBSD (5.2). It took me for ever just to set it up how it is...

Thank you in advance,


Oh btw, when I fix this, I would also like to know how a user can be changed to have superuser status.

March 22nd, 2004, 03:16
Here's your answer ( While you are in there, re-edit your /etc/passwd file, and /etc/groups file, to where your user is not part of the operator group.

As for the 'su' ability. Just edit /etc/groups and add your username at the end of the "wheel" line with a comma after "root".

You really shouldn't give a user the ability to run everything without "su" or "sudo". Just put them in wheel and use 'su' for all your root-like needs.

March 22nd, 2004, 17:40
Not that I am complaining and doing this seems much easier than re-installing the os, but does this solution seem too easy for someone to aquire root's password?

Just asking. I will try it tonight. Thanx.


March 22nd, 2004, 20:08
Hello Kernel_Killer,

Well, I tried what you gave me and I was able to log in as the user (me).

But, root (for some reason) is no longer an user and toor seems to be the new guy in charge. I tried changing toor's password and it gave me an error (I sorry, but I did not write it down).

Also, when I logged on as the user and tried su, su said 'sorry' (Now, wasn't that polite way for su to say 'nice try, but go f**k yourself').

Any more assistance will be appriciated!

Thank you in advance...