March 25th, 2004, 21:21
Hi All

I have been trying for some time now to play and audio CD through FreeBSD with no success. I can play MP3's through XMMS, and sound is working, however, CD's just wont work. xmcd,
The commands I have used so far are
sudo xcdplayer -device /dev/acd0c
sudo cdplay -d /dev/acd0c
xmcdplayer -device /dev/acd0
cdcontrol -f /dev/acd0c
I have also tried the KDE CD player without sucess, xmcd, xcdplayer and cdplay all see the disc - that is they read and disply the title, and the seek bar moves, but no sound comes out. I have tried to run them al as root, just incase sudo wasn't quite getting everything. when trying to mount the drive with a cd in it using the commands
mount -t cd9660 /dev/acd0a /cdrom
seems to work but gives no sound.

sudo mount /dev/acd0a /cdrom
mount: /dev/acd0a on /cdrom: incorrect super block

sudo mount /dev/acd0c cd9660
mount: /usr/ports/audio/xcdplayer/cd9660: No such file or directory

Just trying to mount the systems (sudo mount /cdrom)
cd9660: /dev/acd0c: invalid argument (sometimes it says file system not recognised)

I have a bit of a mongrel box ATM, I went out and bought a 'bargain' which lumbered me with and Ali chipset and a SIS controller, which means every distro there is gives the contigmalloc:1 error. FreeBSD (to the rescue) 4.7 release works great, this is the first 'major' I have had with it (not including the times I tried to cvsup, soon as you lose that 4.7-release tag, the malloc error comes back and the systems goes down for good, took me about 12 installs to work out wtf was going on)
I dont think that the error is connected, but then again, I have been through quite some trial and error, hope someone can help me here, I have been through the handbook and Googled my head off, tried a zillion combos, - I am stuck.

March 25th, 2004, 22:47
First thing that comes to mind is 'audio cable'.

March 25th, 2004, 22:54
mount -t cd9660 /dev/acd0a /cdrom
seems to work but gives no sound.

I don't think you can mount an audio CD, since it has no FS. I'd also go with Optyk's suggestion, check your cables.

March 25th, 2004, 23:11
Thanks, Ill try that, I had considered that option but thought that as I can play cd's with MP3's on them from that device through xmms, that it would not be the audio cable. Will pull the hood of soon as I shutdown.
Thanks all - geez, I am always amazed at how quickly questions are answered here. This post had only been up for 30 mins or so. Takes longer than that to get answed on any phone support line I have ever called. Screaming Electron rocks.

March 25th, 2004, 23:33
MP3s, since they are compressed, are not regular CD audio and do not travel through the CD-ROM audio cable but rather are read as any data file would be, then processed through your MP3 player, and then spit out through the soundcard. The lack of an audio cable seems to be a likely culprit.

April 7th, 2004, 00:33
Hi All

I finally got around to pulling the cover off yesterday. I have a CDRom and a Burner installed, think I was specifying the wrong drive. I changed the audio cable over to the burner - which is the master- and all is well. I would have hooked both up, but the motherboard only seems to have one cd input (onboard sound). Thanks all, much appreciated. Thanks also for the inside info on how it all works Atlas.