April 15th, 2004, 01:16
Hey All

Seems that I have lost Bloody gettext, that rotten port is the bane of my existance. Everytime I try to attempt to upgrade my ports or repair the package database, I end up installing the new version of gettext and kill my machine. Rahhh, can't run a simple xterm under the gui. Gkrellm wont build (pango is also not working since the new gettext). It exists in /usr/local/lib, however, it is needed in /usr/libexec. I have tried symlinks and copying the file, but none of the above works. I ran portupgrade -a -O which repaired more problems than I realised I had, and gave portupgrade -rf expat -m BATCH=yes, but is still causing problems. I am using 4.9-STABLE on a P2 PC. The problem started when I lost, which I retrieved by reinstalling gmake. Think I might be reinstalling again. Any ideas ?


PS Just read the xterm borked post, sorry if I have cross posted, I dont have, so I can't try this option

April 15th, 2004, 19:01
Hey All
portupgrade -rf expat -m BATCH=yes

portupgrade -rf gettext -m BATCH=yes

Geez think they would have fixed this shit, it's over two years old.

April 15th, 2004, 19:28
soup told me to use
portupgrade -aRr
when updating all ports, try that?
symlinking expat (new to old) also worked for me

April 30th, 2004, 02:36
Thanks All
I did go to and followed the instuxtions i.e.
portupgrade -rf gettext -m BATCH=3Dyes
Whew, 4.5 days to complete on my poor old P2 hehe. Fixed it though, just a mrginally better solution than a reinstall LOL. Didn't get them all, but at least 95% of my old build works again. Back now to find out what the story is with pango. Seems to be broken now, I have a couple of ports that tell me can't be found, and gnome2 wont start anymore. (ran the recommended upgrade script as well). I'll post the answer if I manage to resolve the issues.
Thanks Again
PS, The new look is great. Top job screaming electron.