May 17th, 2004, 16:14
Anyone having any issues with a fresh 3.5 FTP/HTTP install using both /3.5/i386/floppy35.fs and /snapshots/i386/floppy35.fs.

I've ruled out floppy issues as I've used dd and rawrite on two different boxes, with new and old 1.44M floppies.

I complete pre-installation configurations and get a connection working. I've jumped back into the shell and hit a few FTP sites to make doubly sure of this.

When I select a mirror, half the time I recieve invalid tar headers for the install sets, enough to halt the install. The rest of the time, I manage an install but I gain link issues, such as firefox issues. And to top it all off, when I don't have any link issues and no corrupt archives, I have an unstable machine.
Whenever I try to install a package (any package). I guess this could be a perl issue as I don't have this trouble in the ports..

Does anyone have any relevant info/advice for this please.

May 17th, 2004, 18:04
hmmm, I've installed 3.5 a bunch and haven't seen any problems. I typically use the secsup mirror if that helps.

Migh also try to verify that the mirror you are trying to use has a valid copy of 3.5 sometimes mirrors bork the rsync.

Now are you installing the latest snapshot or -RELEASE.

Snapshots were recently having problems according to an article on undeadly. If you're trying to install a snapshot I'd try to install -RELEASE cvsup to current and then make build from there and if I was going to be installing current a lot I'd setup a make release machine which built releases every couple of days. 'man release' for more info on that.

May 17th, 2004, 22:52
What does a dmesg say? Sounds like NIC problems.

As for floppies, use `cmp /dev/rfd0c floppy35.fs` to verify it's a good floppy, and compare `md5 floppy35.fs` to the CKSUM file to verify your image is good.

May 18th, 2004, 02:22
Sorry, it seems like I missed out a little info.
I've tried all the mirrors closest to my location, I resorted using the main canadian site, and a finnish debian http server.
My NIC (rtk8139 chip onboard), is currently at work in Windows, I have no trouble streaming radio. I've just checked the md5 sum, tis correct (should of checked sooner :icon_redf )

The dmesg hasn't been checked, I assumed the connection was 100% as good as it can be, I was using the NIC in a previous 3.4 install.

I've tried both release and snapshot. Both with varying degrees of failure. I'll check out the man page, thanks for the tip.

I'll give the secsup mirror a go while im at work, thanks for the tip there.

I guess as a last resort i could always install 3.4 and upgrade manually right... tis the one thing i was trying to avoid :2gunsfiri

Ill update tonight, have a good one guys