July 11th, 2004, 04:16
For some reason my F1-F12 keys don't work. I'm using a Logitech Internet Navigator keyboard through a KVM switch. Everything else seems to work except for these keys. Is there a way to see dead keys, and output of each key? I know there was an app I used under Linux, but forgot the name.

Strog, did you have this problem with yours?

July 11th, 2004, 04:32
One more thing to add. Is there another way to switch consoles? Maybe a way to change the keys to switch them? I would change keyboards, but this is the only keyboard that is PC/Mac compatible and I have a Mac on the switch.

July 11th, 2004, 04:52
Ok. This is truely weird. I put the KVM on the Windows system, and upluged the wireless receiver for the keyboard and mouse. I them went to test it on my Wife's system which wasn't on the KVM. I pluged it in to check to see if those keys truly did work. They did, an I then siged with relief. After that, I pluged the receiver back into the KVM. On the Win system, I had to reboot for the Logitech driver I had just installed, and the Function keys worked fine. OK WTF. Then I went to the BSD system. They then worked fine as well! Truly truly odd. Kinda like what I have to do for my mouse. I'll post that elsewhere though.

July 14th, 2004, 04:15
I noticed when I was using a omni 4 view switch that sometimes the keyboard and mouse would go flaky if I switched off or on a console view that was in the POST part of boot up.

July 14th, 2004, 17:41
use xev to see the output of each key

July 15th, 2004, 08:28
Thanx molotov. That's a good one to have on hand.

Both of the KVMs that I've used have had an equal amount or weird flukes, and they are never the same. Just never know when that's the issue.

August 11th, 2004, 07:59
I have the same keyboard and I often find myself wondering why my Fx keys don't work.. it's normally because the keyboard defaults to f-lock off turning the Fx keys into multimedia keys. So before doing cool hacks, check the setting of f-lock.