July 12th, 2004, 09:43

I am using FreeBSD 4-10. I bought a Cyber 2s1p Plus card so that I can have a 16650 serial port. In my kernel configuration file, under the serial (COM) section, I added the device puc. I also put in the option PUC_FASTINTR.
Compiling the kernel with these items allows me to have cuaa4 and cuaa5. However, They are still 16550 ports.
I read in the LINT file that I need to add the 0x20000 flag for sio in order to make them work as 16650 ports.
I do not know how to do this.
I have tried adding the following lines, in the serial (COM) section, with no success.

device sio4 flags 0x20000
device sio5 flags 0x20000

I think I have to give some sort of location before the flags, but I do not know what to enter.

Thanks for any suggestions,

July 12th, 2004, 09:51
Found this in a kernel faq section, maybe it will help:

8.4. Why do I get interrupt conflicts with multi-port serial code?

When I compile a kernel with multi-port serial code, it tells me that only the first port is probed and the rest skipped due to interrupt conflicts. How do I fix this?

The problem here is that FreeBSD has code built-in to keep the kernel from getting trashed due to hardware or software conflicts. The way to fix this is to leave out the IRQ settings on all but one port. Here is an example:

# Multiport high-speed serial line - 16550 UARTS
device sio2 at isa? port 0x2a0 tty irq 5 flags 0x501 vector siointr
device sio3 at isa? port 0x2a8 tty flags 0x501 vector siointr
device sio4 at isa? port 0x2b0 tty flags 0x501 vector siointr
device sio5 at isa? port 0x2b8 tty flags 0x501 vector siointr

July 13th, 2004, 09:16
Thank you.

I have not tried your suggestion yet, but I will.
Because the box that I am working on is my working router, I am afraid to experiment very much with it. If I take it down, or mess it up, everyone gets upset. If they have no internet connection, it's kind of like a death in the family.

I am going to set up another machine to tinker with. It may take a few days. I will report back if I have any success.

Thanks again,