Amicus
July 13th, 2004, 16:41
It was cheap. It works well...however, it won't install openbsd :(
I'm wondering if I should scrap the whole idea of using obsd on this and just stick with linux or tryout freebsd. I've googled for trap type 6 errors and I surmised that it has something to do with memory possibly (?). Tried other memory chips, ran memtest86

Here's output from using a boot floppy (floppy35.fs with rawrite). Same happens with official 3.5 CD.


boot>
booting fd0a:/bsd: 3281040+189412=0x34f5fc
entry point at 0x100120*&*
Copyright (c) 1982, 1986, 1989, 1991, 1993
The Regents of the University of California. All rights reserved.
Copyright (c) 1995-2004 OpenBSD. All rights reserved. http://www.OpenBSD.org

OpenBSD 3.5 (RAMDISK) #161: Mon Mar 29 12:53:24 MST 2004
deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/RAMDISK
cpu0: Intel Pentium III ("GenuineIntel" 686-class) 798 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MC A,CMOV,PAT,PSE36,MMX,FXS
R,SSE
real mem = 534818816 (522284K)
avail mem = 492216320 (480680K)
using 4278 buffers containing 26845184 bytes (26216K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(e3) BIOS, date 11/05/02, BIOS32 rev. 0 @ 0xfd890
apm0 at bios0: Power Management spec V1.2
uvm_fault(0xd0439fa0, 0xe000, 0, 1) -> e
fatal page fault in supervisor mode
trap type 6 code 0 eip 2fdc cs 40 eflags 10046 cr2 e988 cpl 0
panic: trap type 6, code=0, pc=2fdc

The operating system has halted.
Please press any key to reboot.

I was hoping that someone could point me in the right direction. Any help is greatly appreciated. Thanks
-Amicus

Atlas
July 13th, 2004, 17:02
Well, to preface, I know nothing about OpenBSD. However, should you decide to go the FreeBSD route, I have been running FBSD rather successfully* for about a year now on an Inspiron 8100 and would be happy to share the (very few) config tricks I know. Best of luck!


*only thanks to the patience of SE :)

frisco
July 17th, 2004, 14:25
Try a snapshot and if that gives the same error then submit a bug with the boot messages from the snapshot.

Might also check the mail archives to see if anyone posted a similar error (try searching for the last error message - uvm_fault).

good luck

thedude
July 18th, 2004, 14:17
How's power management on that 8100 going?

Amicus
July 18th, 2004, 17:50
boot -c and then UKC> disable apm0 got it past that part. However it then locked up at detecting fd0. No panic, no nothing...just locked up. I'm going to play around with disabling things to see what all is causing a problem and see if I can at least get it going with display and network.
I looked at the list in UKC but couldn't find ACPI. Does disabling apm0 take care of ACPI as well?

Unfortunately in the inspiron 2500 bios there aren't many things I can change. I've got the latest bios revision but it's still bare. They don't want the end user to break anything I suppose.

Atlas
July 19th, 2004, 08:21
How's power management on that 8100 going?
Once I read all the relevant documentation (duh!), I enabled APM in the kernel with a few flags (don't remember offhand) and things seem a lot better. </offtopic>

thedude
July 28th, 2004, 01:13
So can you suspend or what functionality do you have?

Atlas
July 28th, 2004, 09:24
I never got hibernate to work, which is a real bummer, but I can suspend the box... sort of. If I have my Cisco wireless card in, the machine won't come back. Lately, I've been using a ThinkPad T30 for work and all it has is Windows, so I haven't really tried chasing down the wireless problems on the Dell.

Amicus
September 18th, 2004, 13:09
3.6/snapshot works with apm disabled. I'm running fluxbox right now and it's great. I'm gonna read some documentation and see what flags I can set for apm so maybe I can at least get battery status (right now I'm waiting for the "almost dead" beep). Suspend or hibernate would be cool as well. I'll post an update shortly for anyone who is interested.