August 10th, 2004, 02:48
hello again!

I've got a fresh as pie installation of FreeBSD 4.10, and I've gotten the built-in nforce networking going and I can ping things and so on. My new problem is dhclient. Whenever I run dhclient nv0 I get one and a half screens of error text starting off with ERROR: No bpf devices and then telling me that I need to make sure that I have a real version of dhclient and that I need to make sure that dhclient is fresh.

I have bpf compiled in the kernel, I'm RUNNING the new kernel ;0) and I've run /dev/MAKEDEV bpf0

ls /dev/b* returns
bpf0 bpf1 bpf2 bpf3

So why doesn't this work? Dhclient SHOULDN"T be screwed up, this is the latest ISO of the stable branch!! I hope someone's seen this problem before, it doesn't seem to be on google barely at all... :0( someone please help!

My humble thanks

August 10th, 2004, 11:11
Are you passing any options to dhclient? Any way we can get a screen shot of those errors?

August 11th, 2004, 06:57
I've tried both without passing anything and with dhclient nv0. Also I've tried as a regular user and as root and the dhclient in /stand and /sbin.