November 30th, 2002, 09:20
I have never before had any trouble with sound and OpenBSD.
Before I used to just install and sound would work or I had to do something really simple to fix it but now...

Sound used to work fine with OBSD 2.7-3.0 then I installed 3.1 and nada.

The system says the drivers are fine and everything is set up right.
Sound blaster compatible etc etc.

And I can play cd's fine but when I go for those mp3's it just sits.

mpg123 says its decoding... but I hear nothing..and yes my mixer levels are all up.

Xmms says /dev/audio cant handle 44100 hz, so i tried putting it to 1:2 downsampling and it hangs when I try to play.

Have any ideas what this could be?

Computers a dell lattitude cp, 233mhz,128m ram, soundblaster compatible card

Thank you.

December 2nd, 2002, 10:45

sorry for the late reply, it's been a holiday weekend. Anyways, I seem to remember someone else posting about a similar problem on a while back. Anyways, I've got an OpenBSD 3.1 workstation here I've just never configured sound on it. I'll take a look at it today. In the meantime, someone else might hopefully have a more immediate answer.

One question I have is, Why not 3.2?

December 4th, 2002, 15:32
Hey I got this working fine on my 3.1 box. Perhaps you have a bad port or something. Have you tried to remove the package and recompile and add it? Did you pkg_add this from a precompiled binary?

December 5th, 2002, 14:59
I installed it from the OpenBSD binary library. I also tried mpg321, xmms, ksmp3play, they all do the same thing. Start to play the first second of the mp3 and then hang. I installed 3.2 and tried playing with it and the same thing happens.

December 5th, 2002, 16:35
Hmmm.... it's a notebook right? I had similar trouble (though I think it was FreeBSD) on my Toshiba Sat Pro 6000. It was irq's. grepping dmesg for irq should give you some idea how much stuff is being globbed onto specific irq's. Be sure to turn off "plug and play os" or similar in your bios.

December 9th, 2002, 01:27
ok, I fixed the sound. Just had to guess and check port/irq/drq but after a couple of tries it worked. Now everything works on my little laptop.

Thanks for the Help.


December 9th, 2002, 13:20
ok, I fixed the sound.

Music to our ears :roll:

I trust you're familiar with MFH?: