September 2nd, 2004, 01:27
Due to the new Fry's Grand Opening sale here in Atlanta, I now own two new 120 gig 7200 RPM WD hard drives (30 bucks each, after rebate). I decided that, since I am a BSD guru* now, I would go ahead and use vinum to create a striped array for these two disks and use that as a file serving point.

Well, everything worked and I've got the array in place and mounted as /mnt/raid. When I try to do any writes to the array, though, I get really slow speeds. NFS transfers are ungodly slow while FTP will start out around 9 MB/sec (from the machine next to it via x-over) and then proceed to drop to 440k/sec or so. Reading from the array has been pretty quick.

DMA is enabled on both of the drives, I'm running FreeBSD 5.2.1 (GENERIC for the moment since I just built this box) and the / (along with all the other OS-related slices) are on a SCSI drive mounted at da0.

Does anyone know why my striping write speed sucks so bad? Or is this just how vinum is?

BTW- here's the vinum.conf file:

drive ad0 device /dev/ad0s1d
drive ad2 device /dev/ad2s1d
volume raid
plex org striped 256k
sd length 0 drive ad0
sd length 0 drive ad2

*not a BSD guru; shouldn't be allowed to use anything with more processing power than a toaster.

September 2nd, 2004, 18:28
D00D! That Fry's is open now! We gotta go!

By the way, you're striping speed might suck because of the ileave specified. What's your ileave?

September 2nd, 2004, 23:18
I have to admit that I haven't the foggiest notion of an ileave and Google, startlingly, failed me on this specific point. Where would I find this value and how would I change it?

September 3rd, 2004, 01:18
Apparently, this is in the wrong forum as I think it's a network problem now; when I copy files from the local SCSI disk to the RAID array I get OK performance (not what I was expecting, but there are a lot of sources of potential slow-down here, not the least of which is the 7 year-old adaptec card and seagate drive).

The problem comes in when I copy to the RAID array from any network source including mounted NFS, samba shares, or FTP. Speeds are good to the local SCSI disk (~8MB/sec) but to the RAID is when I start to get the 140K/sec.

Any guesses?

September 6th, 2004, 21:13
I (sorta) solved the problem for now by replacing the AMD network card (pcn0) with an old Z'NYX 4-port NIC from a Nokia IP 440. No more speed issues when writing to the RAID from a network source. I'm still curious as to why this was ever a problem, but at least the tactical problem is solved. :icon_smil

September 7th, 2004, 16:00
Test disk speed separate from network speed separate from nfs speed separate from ftp speed.

In other words, get something like IOZone or Bonnie++ on the system and run it to get pure disk throughput. Then you can test network speed between the two machines using something like tcpblast or netperf. Now you can test NFS/ftp speed via large file transfer and come to some sort of conclusion. But without knowing where the bottleneck might be, it is silly to blame vinum when a slow NIC is to blame.

In your case it seems that the pcn driver is of poor quality and/or the AMD card is of poor quality. On most of my machines i use intel cards, they seem to perform well.

September 7th, 2004, 16:26
Well, I did test a file transfer from another machine to the local SCSI disk and there was no problem with throughput (7-8MB/sec). Things seem to be better now, but I want to be able to pull the Z'NYX card for other applications, so I'll probably check out a 3Com or Intel card later.

I've never had problems with the pcn driver or the AMD cards before; they're what come standard in the HP Kayak series workstations. It's a head-scratcher for me...