September 23rd, 2004, 15:07
Here we go again :)

By the way, thanks for the tip about making my own iso image, that was not at all difficult and worked perfectly.

According to dmesg, the sound card is detected (generic kernel).

sb0 at isa0 port 0x220/24 irq 5 drq 1: dsp v3.01
midi0 at sb0: <SB MIDI UART>
audio0 at sb0
opl0 at sb0: model OPL3
midi1 at opl0: <SB Yamaha OPL3>

and this the start of audioctl -a


the output of audioctl -a is much longer, if necessary I will post it.

I have installed mp3blaster and mpg123 from packages but I have no sound. However, if I do something like

$ cat <bigmp3> > /dev/audio

I get a lot of noise from the speakers, so in theory it is working!

Any tips? I know, it is not absolutely necessary, but it is nice to have :)

September 23rd, 2004, 15:53
make sure youre using the right device to have mpg123 output to, check the man page for the option.

September 23rd, 2004, 20:24
You probably thought of this already, but it has fooled me a few times: have you played with the mixer settings? The default volume always seems to be zero. :-)

September 24th, 2004, 02:27
* molotov: thanks for the tip. I tried that option with mpg123 and I get some noise, but it's definately not music what I hear :(, just noise from the speakers.

* bmw: the mixer was not the problem, unfortunately. The volume is now 88% according to aumix. Thanks anyway for the suggestion.

September 24th, 2004, 08:18
update: I can listen to music cd's with cdio, sounds great. But mp3 files are still not working (they are my own, I swear ;))

September 24th, 2004, 09:37
Maybe a codec missing? If you are running X, you might give XMMS a shot. At least then you could also test with different sound drivers and such.

September 24th, 2004, 19:17
is it only with mp3? did you try wav or ogg?
check your mixerctl setting.. especially the mute ones.


September 26th, 2004, 05:14
ok, problem solved :)
Nothing to do with OpenBSD, really. Examining dmesg I noticed that the sound card used irq5, but in the BIOS it said irq7. Swapped that with the parallel port and now I have sound for my mp3. Only with mpg123, though, mp3blaster sounds really bad. I do not know why. Anyway, thanks for all.