December 7th, 2002, 15:02
I am a BSD newbie but I have used linux for several years now and I want to see what OpenBSD is like. I had also tried to boot FreeBSD and had similar problem. Half way throug booting up it freezes. I have used several OpenBSD disks and the same thing happens.

December 7th, 2002, 15:12
What are you using to create the boot disk from? dd or rawrite?

December 7th, 2002, 15:16
dd if=floppyxx of=/dev/fdo

December 7th, 2002, 16:15
Hmmm... I'm not sure if anyone else does this or if it's even a supported way to make an OBSD disk but I usually just:

cat floppy31.fs > /dev/fd0a

Seems to work fine for me. At least I've never had a problem.

December 7th, 2002, 16:29
dd if=floppyxx of=/dev/fdo

from the FAQ
[code:1:3782cfeee3] - Creating floppies on Unix.
To create a formatted floppy, use the fdformat(1) command to both format and check for bad sectors.

# fdformat /dev/fd0a
Format 1440K floppy `/dev/fd0a'? (y/n): y

If your output is like the above example, then your disk is OK. However, if you do not see ALL "V"'s then your disk is most likely bad, and you should try a new one.

Once you have a clean, formatted floppy it is time to write the installation image to floppy. For this, you can use the dd(1) utility. An example usage of dd(1) is below:

# dd if=floppy32.fs of=/dev/rfd0c bs=32k

Once the image is written, check to make sure that the copied image is the same as the original with the cmp(1) command. If the diskette is identical to the image, you will just see another prompt.

# cmp /dev/rfd0c floppy32.fs

try doing all those steps, then using the floppy provided it passes all those steps. if it still errors out, copy down the exact words before it errors out. "halfway through boot it freezes" doesnt give much to go on. if your floppy is good (which the above steps will help verify) then it is probably an incompatible driver of some sort, but it will be necessary for us to know the exact words on your screen to help you diagnose such a problem.

good luck

December 7th, 2002, 17:19
Ok sure thing.. I did format floppy and didnt get any erros but did put the bs=32 thing will try that thist after work...

December 7th, 2002, 22:40
I followed the exact instructions and it stops at:

[code:1:a66e04f4f4]scsibus1 at atapiscsi: 2 targets[/code:1:a66e04f4f4]

December 7th, 2002, 23:39
I followed the exact instructions and it stops at:

[code:1:643bfc7705]scsibus1 at atapiscsi: 2 targets[/code:1:643bfc7705]

i bet it's having a hard time with your cd drive(s).

let it sit at that prompt for 5-10 minutes, maybe it will come back after some time. if it does, you'll probably see some error messages and then it will continue. if it hange there for more than 10 minutes, then try either unplugging the cd drives and booting up, or at the 'boot >' prompt, type in 'boot -c'. this wil get you to a 'ukc> ' prompt. at that prompt, type in 'disable cd* [enter] quit', then it will continue to boot up witht he cd drivers disabled and you should be able to get fully booted up.

if you're wondering which cd drive, it should be whichever is plugged into the second IDE channel.

try all that and report back...

December 8th, 2002, 00:29
ok that works now I have a partition that is reiserfs and I labeled it openbsd when Im in the install I tell it it about that partition and it fails at mounting it.. Duh but shouldnt it try to formati it first? or how can I format it in linux

December 10th, 2002, 12:56
Hey gmoreno! Glad you made it here :D

I am confused though as to what you are trying to do. I would use the normal BSD filesystem as the root, home, and any /usr partitions you have. Now if you are just trying to mount an already existant reiserfs partition, mount may not know it explicitly and may need to be told to use reiser with the -t <fstype> option.

December 10th, 2002, 13:02
gmoreno, forget dealing with reiser: it aint supposed to work (

December 10th, 2002, 14:03
Well what I am trying to do is install OpenBSD on my /dev/hda4 partition that currently is reiserfs but that I have set tha flags to OpenBSD. My other partitions on the hardrive are linux and windows... Now let me try to be clear about what happens...

I boot of the floppy then I select install then it gives me fdisk and I select /dev/hda4 for my / partition. Then it asks me to label it but I hit a key to exit that then it tries to mount the partition and tells me that it failed...

That's where I am at.

Nice to see you here Schotty. Where's your redhat :wink:

December 11th, 2002, 13:31
Nice to see you here Schotty. Where's your redhat :wink:

Well, Saitoh is my favorite anime character, and from my favoroite anime. So since elmore had the image in there -- I had to go with it.

Well, I may be hearing ya a bit wrong, but in bsd it takes whats called a slice and you partition that. So if you have, oh say ... a 10 GB hard disk, and want 4GB for Linux, 4 GB for windows, and 2GB for OpenBSD, you would need at least 5 partitions (/boot for linux and to hold the bootloader, / for linux, linux swap, c: for windows, and a OpenBSD slice.) Now if you really wanted to go and customize the BSD slice after that you could. You could make 4 512MB partitions out of it or leave it whole (minus enough for some swap space).

What You are going to need to make sure exists is another primary partition is available for a slice. For example, if on your drive you have hda1, hda2, hda3, hda5, hda6 all used up with say .... hda1 as the /boot, hda2 for windows, hda3 as an extended containing hda5 (linux) and hda6 (swap) you would need to put any free space to hda4. The BIOS and most OS's have issues trying to make an extended partition boot. I recall having multiple issues with win95/98SE and Linux due to that same issue. I dont know how OpenBSD fares, but FreeBSD fits in the same category.

December 11th, 2002, 14:37
From reading this I might not be able to install OpenBSD right now I might have to reinstall everything... this is my current setup:

Device Boot Start End Blocks Id System
/dev/hda1 1 1020 8193118+ b Win95 FAT32
/dev/hda2 1276 1305 240975 82 Linux swap
/dev/hda3 1306 2491 9526545 85 Linux extended
/dev/hda4 * 1021 1275 2048287+ a6 OpenBSD
/dev/hda5 1306 2059 6056473+ 83 Linux (/)
/dev/hda6 2060 2491 3470008+ 83 Linux (/home/gmoreno)

Now /dev/hda4 only has the tag set to OpenBSD but it is actually a reiserfs partition.

December 12th, 2002, 15:10
looks to me like you can. Remember, BSD uses one whole partation to host all of them. Slices are that. So you should be able to do it.

Anyone see anything wrong ?

December 12th, 2002, 16:03
heres some links to help you figure out partitioning ;)

Also, remeber that many of the OS's will want to have the kernel under the 1024 limit as well.