November 22nd, 2004, 22:39

my first admission: i'm a freebsd novice. however, i have no problems delving deep into the man pages, handbooks, and how-tos to solve a problem. alas, i'm stuck and i humbly ask for your help.

i'm having trouble installing freebsd on a laptop. my laptop shuts down regardless of which mode (default, safe, etc.) i choose. because of this, i can't reach the kernel configuration menu.

i tried to disable acpi by following the instructions in the "Using and Debugging FreeBSD ACPI". SET hint.apic.0.disabled="1". it didn't work. i tried searching the freebsd mailing list, in which someone had a problem mirroring mine:


the suggested solution was to disable acpi in bios. unfortunately, my laptop does not have the option to do this. also, i do not have a floppy drive, so that's unfortunately one fewer method to install freebsd.

on a side note, netbsd boots up just fine. still, it is my wish that i can get freebsd up and serving on my compaq presario r3210us. thanks!

November 22nd, 2004, 22:51
Hey endymion Welcome to SE! We're glad you're here. Unfortunately I don't have acompaq to test on but I'm sure someone will get to you reasonably quickly. What version of FreeBSD are you trying to install?

November 22nd, 2004, 22:59

thanks for the cordial welcome. i'm trying to install version 5.3. in the mailing list, the gentleman mentioned that regardless of which version he used (3.5 - 5.3), he faced the same problem.

November 23rd, 2004, 01:17
I'm going to suggest all the usually hardware troubleshooting methods.

Disable everything you possibly can in the bios (parallel, serial, usb, plug&play, etc.) and try it again. If it works then you can systematically enable them until it breaks again.

If you have multiple sticks of memory, pull them and try one at a time. Try to find one to borrow long enough to test if you only have one.

Update to the latest available bios for your laptop.

Choose 6 on the boot menu to get to the boot prompt. Type unset acpi_load and then boot to make sure ACPI is explictly being disabled.

If you can let us know which model and specs you have then perhaps we can suggest something more specific (maybe we can't but I'd like to try :squarewin ).

November 23rd, 2004, 02:40
I had the same problem with my former laptop (Vaio). The 5.x CD had issues with ACPI and rather gave me various errors, or locked, but with 4.8, no issues at all. So what I ended up doing was booting off the 4.8 install CD, and going into options, and changing the version to be installed. Once I was done, 5.x was installed and ready to go.

November 23rd, 2004, 03:09
strog: the compaq laptop's bios does not have the option of toggling acpi, pnp, etc. i guess this will be the first and the last compaq product i'll ever own. i also tried disabling acpi before booting the kernel (option 6, set, boot). but to no avail, yet. i will definitely try pulling out the memory sticks though.

kernel_killer: i'll try using an older version, then upgrade to 5.3. it's great that the handbook is super lucid and complete on doing this (and probably 99% of my newbie questions).

laptop specs: compaq presario R3210us
1.6Ghz AMD Mobile M
256M + 512M PC2700 DRAM
32M Nividia GeForce4 Go
Nforce3 chipset

again, thanks for the pointers so far. prior to joining SE, i've been monitoring the threads on this forum and reading the handbook, hoping to solve this problem behind the scenes. i'm almost there, just a little more tenacity will do it.

February 10th, 2005, 19:21
I am having the same problem on a new hp pavilion zv5200. Auto turnoff of the laptop from initial install screen. I also have no bioos options. Had any resolutions yet?

February 10th, 2005, 22:07
i believe someone had successfully installed FreeBSD 5.3 on his
R3000 laptop, which is related to your Pavilion. the install is not
without a bit of hacking.