December 2nd, 2004, 17:26

I did install OpenBSD 3.6 and all the other goodies for a webserver from pkg. Everything works fine just postfix sends but doesn't receive mail:

telnet on port 25 from the outside works fine

no errors in mailog

my postconf -n is:

pick# postconf -n
alias_database = hash:/etc/aliases
command_directory = /usr/local/sbin
config_directory = /etc/postfix
daemon_directory = /usr/local/libexec/postfix
debug_peer_level = 2
html_directory = /usr/local/share/doc/postfix/html
mail_owner = _postfix
mailq_path = /usr/local/sbin/mailq
manpage_directory = /usr/local/man
mydestination = $myhostname
mydomain = darktech.org
myhostname = pick.darktech.org
mynetworks_style = host
myorigin = $myhostname
newaliases_path = /usr/bin/newaliases
queue_directory = /var/spool/postfix
readme_directory = /usr/local/share/doc/postfix/readme
relay_domains = $mydestination
relayhost = [smtp1.sympatico.ca]
sample_directory = /etc/postfix
sendmail_path = /usr/local/sbin/sendmail
setgid_group = _postdrop
unknown_local_recipient_reject_code = 550

I guess that there is some configuration issue but at this point everything is just blank.

Any help would be appreciated.


December 2nd, 2004, 19:59
Hi P-M! Does this post mean you have escaped from those nasty Windows servers? :-)

In general, check your logs: read through /var/log/maillogs and see what Postfix says is happening.

But I have a pretty good idea what's really happening. You are being "Sympatico'ed". Sympatico filters port 25 so you cannot connect directly to port 25 on any hosts other than their own mail-forwarders. But also, nobody can connect directly to port 25 on any Sympatico subscriber's machines.

I just tried to connect to pick.darktech.org and got silence.

bmw@hardbop$ telnet pick.darktech.org 25
Connected to pick.darktech.org.
Escape character is '^]'.
... long delay ...
Connection closed by foreign host.

As I too am a Sympatico subscriber, I have the same problem and what I do is this: I have all my external mail delivered to a POP account (eg at Sympatico's supplied account, or Gmail). Then I run fetchmail and have it poll the POP account every 5 minutes. It delivers mail that it picks up directly into the SMTP port on the Postfix server. Boom! All your mail is snarfed and delivered.

December 3rd, 2004, 10:52
Hi P-M! Does this post mean you have escaped from those nasty Windows servers? :-)

Oh no, and they are forcing me to write .NET code too, where is the Human Rights Commission ... ;)

You are absolutely right; Sympatico is blocking both ways now, not like before only sending. I was telnet-ing from another OpenBSD box also on the Sympatico network so that explain why it was "working". I should have thought of it when I didn't see any log entire, dohhh…

Thanks for the answer.

Getting ready for snow? Did you grease your snow blower? I got a new shovel ... for my son!