December 19th, 2004, 00:39
Help! I'm about to pull my hair out!
I've got an A40 Powershot that worked well with RH9 and GTkam.
I finally got it to recognize the darn thing after changing the permissions for usb. ( hope I did that correctly ) But know it says "Could not establish initial contact with camera". After a little research I found that this camera uses PTP transfer and not Mass Storage.
ugen0: Canon Inc. PowerShot A40, rev 1.10/0.01, addr 2

Can anyone tell me what I'm doing wrong?

December 19th, 2004, 01:28
Richard at Tao Security (and SE member!) has a pretty good write-up about this. I haven't worked on this personally; I've just used one of the cheap-o 6-in-1 card readers. It shows up as a mass storage and works pretty easily. You might consider that route if you can't get the camera itself working.

December 19th, 2004, 03:34
Did you run the app as root?

December 19th, 2004, 20:09
I almost feel too stupid to reply, but I ran Gtkam as root. WORKED GREAT!
So is there a way to run as regular user?


December 20th, 2004, 03:00
There is a way, but it might not be worth it to you. I don't remember the process of doing it, but it was brought up here a while back when dealing with CDROMs as well.

December 20th, 2004, 10:15
There is a way, but it might not be worth it to you

you'd just need to chmod the /dev/ugen device or whatever

I use a sandisk 8 in 1 reader myself. Just seems easier.