January 10th, 2005, 06:41
Hello SE. It's been awhile since I been here. I hope some of you remember me.

Anyway, I haven't been using FBSD for awhile, hard drive crashed, but Saturday night, I installed 5.3. I'm having some issues with some things and hope to get it cleared up.

First, I tried installing using the ISO, but it may be a bad burn, because I chose to install everything and when it got to some Perl files, it went into a loop.

Then I decided to do the FTP full install and it looks like it went fine, but when I boot, and the bios screen info start flashing by, it seems to hang around when it gets to the Sendmail line. I usually press Cntl-C to continue with bootup. Is it normal for it to take very long time to start during booting? I don't really need sendmail, so maybe if I can turn it off that will solve that issue.

When I configure X windows(xorg), and installing Xfce4, the command startx doesn't seem to work. It just hangs after pressing the Enter key. I made a .xinitrc file in my home directory but still don't work. I can start xfce4 with the startxfce4 command and no problems.

Then I installed Mozilla and it seems to be taking a pretty long time to start once I click the icon. Maybe about 5 minutes or more before it finally pop up.

Any ideas/suggestions for a fix?


January 10th, 2005, 07:45
First off, yes sendmail sometimes takes that long. On X, it moved to Xorg, so you need to run 'Xorg -configure' as root. Test the new conf file by doing 'X /root/'. If all is well, cp that conf file to /etc/X11/ as xorg.conf. After that, run 'startx' as a user.

January 10th, 2005, 10:24
hey ghostdawg! Welcome back! :)

January 11th, 2005, 05:17
Thnx, Elmore...good to be back! KK, I do have xorg installed and it's working okay. But typing 'startx' still just hangs once I press Enter. I can't understand why it doesn't work, but, oh well. Give me some time and I will try to fix it.

Just trying now to get the basics going good. Thnx for the replies and hope to get more suggestions.

And mozilla still takes along time before it loads. I installed Gnome and will see how it works when I get home.

January 11th, 2005, 06:32
post errors from /var/log/Xorg.0.log

January 11th, 2005, 09:35
No errors in Xorg log. When I type exec gnome-session from CLI, it show error message about GTK2 can't open display, and then it kicks me back to the login screen.

Any other ideas?


January 11th, 2005, 22:14
You need to run from startx, and not 'gnome-session'. You will get errors from doing that (as you know). Run startx and let's see the log it drops as it loading.

January 11th, 2005, 23:03
Ok, tell me how do I set up 'startx' to load Gnome? Now when I type startx, it just hang with no kind of output. I wait about 10 minutes or so and then I kill it with cntl-c.

I have added startxfce4 in the '.xinitrc' file in home directory and when I type startx, nothing happens. But typing 'startxfce4' will open the WM.

But I'm beginning to like XFCE4...this is my first time really using it and it's not bad at all.


January 12th, 2005, 00:21
exec gnome-session

Add that line to your ~/.xinitrc and be sure to comment out anything else that may be in there. If that doesn't work you may have a faulty or partial GNOME install.

January 14th, 2005, 21:35
Thanks all for the replies. Everything seems to be fine, but I actually didn't try the gnome command. But now I have what looks like a different problem.

I did a port upgrade and source upgrade, not the 'portupgrade' command, and now I had gaim installed but it don't run now. I believe the problem is one of the upgrades must have tried to install gnome 2.8, the first install had 2.6. I tried deinstalling gaim and reinstalling but it keep telling me an older version is installed.

But it keeps saying I need some glib files which look like related to gnome 2.8. I would like to deinstall gnome but when I tried, it mention the older version.

How can I get rid of gnome 2.6? All this started when I tried to install through ports, Abiword!

Thnx, hope this make sense.

January 15th, 2005, 03:52
You can always use /usr/ports/sysutils/portdowngrade to get an older version. I'd do that to all your Gnome ones if you don't want to update them all. You are going into the port and doing 'make deinstall' and then 'make reinstall' right?

January 15th, 2005, 19:54
Correct, I'm going into the port and make deinstall & then make reinstall.


January 18th, 2005, 00:40
Well I ended up reinstalling again and so far so good. A few of the glitches still exist but I can live with or without them.

'startx' still doesn't work for some reason. Mozilla still takes about 5 minutes before it opens. And I really like XFCE4. So thnx for all the help.