January 26th, 2005, 05:17
I am having erratic problems trying to install 5.3.

I downloaded an iso and also bough a magazine with a full set of 4 CDs.

Both display the same problem so I conclude it is not the media that are at fault.

The system locks up at various stages of my going through the setup options. At least I should say the keyboard no longer responds.( This is my only input device at this stage so I cannot tell if the system is frozen but I get that impression.)

ie it boots without any issues and it fails before I start installing any packages.

This kind of ramdom behaviour would suggest hardware issues but I have this hardware running Gentoo for about 12 months and it has just done 48 hrs of near continual compiling without a glitch.

So it would appear to be something specific to BSD.

Where should I start to look?

TIA for someone with a bit more familiarity with BSD.

January 26th, 2005, 10:52
What kind of hardware is this?

Some ACPI implmentations on laptops have been problematic.

Have you tried booting with ACPI disabled?

January 26th, 2005, 12:02
Thanks for your reply.

Well it's an Athlon-XP based desktop box.

Yes I did try with ACPI off but it did not solve it.

I seem to have found a solution to the initial problem having read somewhere about instabilities with USB.

I removed a 6 port PCI USB2 card and unplugged the printer from the std on-board USB.

This allowed me to progress a bit further...

NEW issue.

I have a 80-G Baracuda that my BIOS tells me is 38309/16/255 , BSD wants to make it 9728/255/63 and if I enter the correct geometry is tells me it's wrong and goes back to 9729...but warns me I need to refer to the BIOS ....

So I tried /dev/hda a Fujitsu 3.3G , here it allowes me to correct the geometry to the BIOS settings of 847/128/63

I gave it 2G on that device and used Label to set up one slice as /

Since I have 256M of RAM I decided not to use swap.

I already have Grub installed on the MBR of this device so I opted for NONE as boot manager.

Then I selected the packages I needed and went for Comit. (comit as in suicide!)

It failed with its very first attempt to write a package and blew away my boot manager that I said I did not want changed.

I have just restored my system using a Knoppix/Debain boot CD and am a little apprehensive about attempting BSD unless I know it's not going to hose the rest of my system.

If you understand what may be happening here please advise.



January 26th, 2005, 13:24
I had the same problem with the harddrive geometry, look on segate's site and find the geometry they recomend, then set it in the bios/freebsd installer. At least I think thats what I did. However, if you already have data on the drive Im not sure if that would mess with it, anyone else comment on that?

January 26th, 2005, 14:27

I have put the Seagate drive out of bounds for BSD, I have c.60 Gb of date/system that I dont want to reconstruct from fragmented back-ups.

That was why I fell back to /dev/hda that seemed to avoid the geometry issue.

bash-3.00#cat /proc/ide/hda/geometry
physical 6780/16/63
logical 6781/16/63

bash-3.00#cat /proc/ide/hdc/geometry
physical 65535/1/63
logical 16383/255/63

Seems this issue has been around for a while.

Working around the issue by going for /dev/hda can you see why it failed on that drive (please refer back to last post).

many thanks. :cool: