April 20th, 2005, 23:17
Hi all
Having a great deal of trouble building open office 2.0 on FreeBSD 5.4. I am trying to build from the ports, at first, the install was imply halting in the /moz work directory, so i tried the build without mozilla, still no success, now I get
===> openoffice-2.0.20050310 depends on shared library: pango-1.0.800 - found
===> Generating temporary packing list
===> Checking if editors/openoffice-2.0-devel already installed
cd: can't cd to /usr/ports/editors/openoffice-2.0-devel/work/instsetoo_native/*/
*** Error code 2
I have no idea what should be in this directory and if I can download what it wants, I have left a post at the OOo forums over a week ago, no replies, so I tried the unoffical forum as well, got a eply there, but that is not really what that forum is for, still nobody from Open Office seems o be able to help me -anybody else having issues wth this port ? Seen any patches around or heard of a fix ? Latest attempt invloved a make install line like :
/usr/ports/editors/openoffice-2.0-devel #make -DWITH_TTF_BYTECODE_ENABLED -DWITHOUT_MOZILLA -DWITH_GTK -DWITH_CUPS install

still fails with the above error. 1.1.4 was great, I would really like a look at the database component

April 21st, 2005, 00:21
Looks they have the wrong version set for OO. That's an old pango library file. You could always link the existing pango plugin file (/usr/X11R6/lib/ as the file it's looking for.