so solid
May 16th, 2005, 13:16
every where I've searched on the Internet has conflicting information about what to do with rc.conf.

sendmail = none_enable, =yes =no

what is the straight goods on setting up postfix and removing sendmail.

so solid
May 16th, 2005, 13:25
never mind!

May 16th, 2005, 17:10
After you build the postfix port, at the very end, it should tell you how to disable sendmail and make postfix the default MTA. There are a few ways to do it, but I remember something like:


Then, you make a symlink for the postfix startup script in /usr/local/etc/rc.d.

Hope that helps.

May 18th, 2005, 09:34
If it's being installed from FreeBSD ports then all you need to do is run the mailwrapper script, is sets /etc/mailer.conf up for you.

May 18th, 2005, 10:52
I actually went to the trouble of testing the three different methods outlined. I settled on the one posted in my tutorials here on the forum:

I've had the script fail once in awhile (maybe it was me) so I check the details. Changing the links to the commands, making "sendmail" call up postfix seems the best answer in my experience.

so solid
May 19th, 2005, 00:15
well, i figured it out. i shouldn't install it when i do the initial install of freeBSD.

what i did was install plain old freebsd, didn't add anything from the ports collection found on the CD, logged in, went to /usr/ports/mail/postfix-current
and ran make and make install

i followed the instructions that show up after doing make install, to disable sendmail, but when i connect to port 25 of my box it still shows the sendmail banner. i was able to manually shut off sendmail, i just have to figure out how to get postfix to start up automatically instead.

i'll look at the link that someone replied to...

thanks for everyone's help!