May 30th, 2005, 22:31

I'm trying to install and run FreeeBSD 4.5 on a Panasonic CF-25 laptop. Funny thing is this is the only OS that would install on this relic, Linux would crash while trying to partition the HD. This thing is pretty old and I knew there would be problems getting it running the way I want it to. So here is the problem....

Everything installs fine and I setup Afterstep WM. After trying to run the "startx" command I get the following errors.....

execve failed for /usr/X11R6/bin/X (errno 2)
_X11TransSocketUNIXConnect: Can't connect: errno = 2
(This is repeated 4 times)
giving up
xinit: No such file or directory (errno 2): unable to connect to X server
xinit: No such process (errno 3): server error.

I looked for "X" in the dir that is listed in the first line and of course did not find it. So that's what I assume is the first problem, but I'm not sure on how to go about fixing this issue. Can someone tell me what happend and what I can do to correct this problem?


May 30th, 2005, 22:56
You may need to edit your hosts file (/etc/hosts) and include your system's hostname in the line after where it says localhost.localdomain.

Not sure this will solve the problem, but stranger things have happened...

May 31st, 2005, 01:05
What does `pkg_info | grep XFree` show?

May 31st, 2005, 20:10
"pkg_info | grep XFree" doesn't show anything. Anything else?

May 31st, 2005, 22:22
Looks like you don't have X installed. Go into /stand/sysinstall, and then go to Configure and then XFree86 to installed the packages (that is if 4.5 has it. I'ts been so long).

June 1st, 2005, 22:47

Thanks for your help so far.

It looks like it won't install X. I tried it with /stand/sysinstall, post install config, installed Afterstep and when it tried to install, the following errors came up;

A dialog box comes up with;
"Add of package xpm-3.4k aborted, error code 1- please check debug screen for more info. (more)"

(date/time) /kernal: acd0 READ_BIG command timeout - resetting (X2)
(date/time) /kernel: ata1: resetting devices .. done (X2)

After this, it fails to add any packages.

I tried fvwm came up with the same errors. Do I assume that it's the CDROM? or do you think it could be the CD itself? Should I try the latest ver. of FreeBSD?

Throw the :2gunsfirilaptop across the room? :tongue: (last resort)

Thanks again for the help,


June 1st, 2005, 23:32
Yes, you might try 5.4 out. You will most likely have better luck with it.

June 2nd, 2005, 12:36
I tried configing X and getting kdm to replace xdm as in the handbook but that screwed everything up for me in FreeBSD 5.3. Then when 5.4 came out it worked like a charm. now I can login with kde, gnome, xfce, Windowmaker or twm. So far I am completely satisfied with 5.4.
Good Luck.

June 2nd, 2005, 22:38
Thanks to everyone that helped me with the issue I was having.:biggrin: 5.4 installed perfectly and I got TVM work. Now I just need to figure out how to install/configure other WM's.

June 2nd, 2005, 23:21
Just install the packages, and then whatever WM you want to use, put into a new file called .xinitrc in your home directory. That file should have this in it:


exec fluxbox

That's just an example if you were to use fluxbox. Replace with `gnome-session`, `startkde`, `openbox`, or whatever the file is to start your new WM.

June 7th, 2005, 07:51
To start up a different installed windows manager you can use:

echo exec startkde > ~/.xinitrc

Obviosly changing the startkde with the wm of your choice.

June 10th, 2005, 23:10
So far all I can get working in TWM. When I try to install other WM's I get a "READ-BIG error" from the CD-ROM. Since it doesn't have a NIC yet I can't FTP the packages I need. Yet anyway.

Thanks for your help!