June 14th, 2005, 13:32
Hello again!

I've got firefox 1.0.3,1 running on my laptop now and it tells me I can't install extensions because I don't have the latest release, which according to is 1.0.4, so I ran CVSUP but it still says 1.0.3,1 in the makefile, and when I deleted the firefox directory in ports cvsup didn't even replace it (?/!) Am I missing something here? I realize I could just be abusing how cvsup should be used, but I thought that it should at LEAST go fetch the firefox entry again...
And also, would just changing the version = entry in the Makefile be enough to get it to upgrade? Tried portupgrade btw with no luck at all, it just goes through the pkg_db and then exits. (<- wild guess at what portupgrade is doing....)

June 14th, 2005, 20:20
What tag are you using in your supfile? If you use "." you will get the latest Firefox.

June 17th, 2005, 14:48
I didn't have a tag entry at all! Added
*default tag=.
and cvsup switched to checkout mode, but still no luck, firefox is still getting skipped for som reason... :0(

June 17th, 2005, 18:44
Is it set to 'ports-all' ? I take it you are also running it with:

cvsup -g -L 2 my.supfile


June 18th, 2005, 07:52
yes and yes.
I've run cvsup countless times, with and without my refuse file (just blocks all the unecesary language versions of everything.)

June 19th, 2005, 14:30
Hmm... Does anyone know another forum where I could ask about this? Can't use portupgrade either since it complains that there's no directory in ports for firefox, I'd really like to get this worked out

June 19th, 2005, 15:26
So /usr/ports/www/firefox doesn't even exist? If it does, what does distinfo show?

Did you try going to the FreeBSD FTP server and downloading the tgz file, and using pkg_add to install it?

Here's the supfile that I use, and you might give it a try:

*default base=/var/db
*default prefix=/usr
*default release=cvs tag=.
*default delete use-rel-suffix
*default compress

Of course you could always just use "ports-www" since it's only one port you're really worried about.

June 20th, 2005, 04:24
Nope, it doesn't exist.
My supfile looks just like yours with the exception of the host.
Downloaded the package from the FTP server and tried pkg_add and got r00t[/root/]97%# pkg_add firefox
pkg_add: can't stat package file 'firefox'

and portupgrade gives this:

r00t[/root/]97%# portupgrade firefox
** Port directory not found: www/firefox
** Listing the failed packages (*:skipped / !:failed)
! www/firefox (firefox-1.0.3,1) (port directory error)
---> Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed

July 1st, 2005, 06:21
Gaah! Talk about fundamentally missing the point! >:0(
I went to and grabbed firefox.tar.gz and assumed (I'm not really sure WHY) that this was the package version. When I got my head out of my @$$ and realized it was the ports directory for firefox, I put it in place and *poof* make goes and gets the newest version and starts just fine. Still mystified by cvsup's mal-behavior, but at least firefox is fresh!

Thanks for all the above points and help!