June 21st, 2005, 12:41
I'm trying to get nagios 1.2 with plugins 1.4 running in OpenBSD 3.6. Got the configs working and all, and realized there were some CGIs missing, along with the CGI scripts erroring prematurely.

I decided to start again, and realized that after I ran configure, I recieved an error I must have over looked the first time. It was an error with gd. After looking at some forums, found that I needed to change the LDFLAGS in the Makefile. Now I still get an error from gd, and completely lost now. I'm running configure with the --with-gd-inc and --with-gd-lib options. This is what I get:

checking for main in -liconv... (cached) no
checking for gdImagePng in -lgd (order 1)... (cached) no
checking for gdImagePng in -lgd (order 2)... (cached) no
checking for gdImagePng in -lgd (order 3)... (cached) no

*** GD, PNG, and/or JPEG libraries could not be located... *********

Same thing when running:

env LDFLAGS="-L/usr/local/lib" LIBS="-lttf" ./configure --prefix=/var/www/htdocs/nagios --with-cgiurl=/nagios/cgi-bin --with-htmurl=/nagios --with-gd-inc=/usr/local/include --with-gd-lib=/usr/local/lib

Any ideas? TIA

June 21st, 2005, 16:48
I ran across this while searching a bit.

June 21st, 2005, 17:56
Yeah, that's the first I ran across. That's what I tried. :confused:

June 22nd, 2005, 00:23
There is a nagios port out there for OpenBSD (unofficial last time i checked). You might try looking at that.