July 3rd, 2005, 14:25
hello, i'm trying to install FreeBSD 5.4-RELEASE.. well the thing is, when im about to get into fdisk, it says my disk has a wrong geometry, so i set the one in the bios and its fine, but,
it doesnt recognize any of my partitions! i have one primary ntfs partition of 40gb, wich has win xp pro sp2, and an extended ntfs one of 14.5gb
my disk is a maxtor 60gb one, the space that's left was allocated to my linux partition, (i had slackware 10 installed on it), but i decided to delete it and try freebsd out..

i have tried everything from creating a FreeBSD (type A5) partition under linux's fdisk, and also tried using partition magic... but it hasnt worked... everytime i get the same geometry error, i feed it the correct values and then i see no partitions, just one large unused one...

what should i do?

July 3rd, 2005, 21:04
Hi fgm, I feel your pain! :-) This aspect of PC architecture is very perplexing and vexing.

First, did you very carefully read this part of the online handbook ...


(Note that what you call partitions are called "slices" in FreeBSD.)

See also:


Good luck with it!

July 4th, 2005, 14:10
yeah i'm afraid i read all that but still got no answer :( this is a really weird problem..

i tried using my friends pc, and it also had the geometry error, but i fixed it and it showed all the partitions that system has already, two ntfs partitions.... so i thought something is wrong with my hard drive's partition table or something