July 25th, 2005, 15:01
"A potential buffer overflow when decoding invalid compressed data
exists in the zlib compression library (installed as libz on OpenBSD).
It is not known at this time whether maliciously-crafted compressed
files can be used to execute arbitrary code but at the very least
there is the potential for a denial of service attack.

Please note that this fixes a different problem that the patch
released two weeks ago.

Since zlib is in wide use throughout the base OS, as well as in
ports, users are advised to patch their systems as soon as possible.

A fix has been committed to OpenBSD-current as well as the 3.6 and
3.7 -stable branches. Patches are also available for OpenBSD 3.6
and 3.7. OpenBSD versions 3.4 and lower are not affected as they
use an older version of zlib that does not contain the vulnerable

The main OpenBSD mirror appears to not be updating at the moment, so
the following urls point to the main USA mirror.
3.6 patch:
3.7 patch:

The 3.6 patch also applies to OpenBSD 3.5."