July 31st, 2005, 18:40

if someone could lend me some assistance, that'd be great. i googled for an answer but wasn't sure if it was the right thing to do.

when i ssh to my box across the internet to my dsl line I get the following:

Permission denied (publickey,keyboard-interactive)

To put this in to perspective, I've got a DSL line with a firewall on it. For the DMZ section I have my wireless network set up, using a Linksys Router with a built in firewall. I've got my ssh box behind the wireless setup. I've opened up the appropriate ports, but I can't seem to log in.

I'm trying to access my ssh box when I'm at work.

I've tried the following:

In /etc/ssh/sshd_config:
I changed #PasswordAuthentication no
to this:
PasswordAuthentication yes

Anyone have any ideas?


July 31st, 2005, 21:23
Are you trying to login as root?

FreeBSD doesn't allow you to login as root by default. It's a bad idea to login as root. Login as a normal user that has su/sudo access.

If you aren't logging in as root then try using a more verbose login to get some more info on what it doesn't like. e.g. ( ssh -v user@somehost)

August 1st, 2005, 00:53
okay, i'm not logging in as root thats for sure.

i tried what you asked me to do with the -v option. i got this.

from the host that i was trying to ssh from, I got the following...

I'll try to google for this as well.

debug: authentications that can continue: publickey,keyboard-interactive
debug: key does not exist: /some/dir/home/jkwong/.ssh/id_dsa
Permission denied (publickey,keyboard-interactive).
debug: Calling cleanup 0x8057068(0x0)

August 1st, 2005, 01:26
i've got some more info. i've never set up ssh before as you can prolly tell.

i managed to generate an id_dsa file. but then i get another message... some sort of failed message. googling now to see what i can find.

Enter passphrase for DSA key '/some/dir/home/jkwong/.ssh/id_dsa':
debug: PEM_read_bio_DSAPrivateKey failed
debug: read DSA private key done
Permission denied (publickey,keyboard-interactive).

generally what do all these messages mean? it looks as if i need to set up sshd properly? and all the keys?

August 1st, 2005, 03:58
not sure about all the errors but may you have set : StrictModes yes

When in strictmode the only one with access to the file must be the owner, no groups / world rights.

Dunno about what sshd defaults to though.

btw i suggest you use key only authentication, it is safer and easier to use when you get the hang of it (PasswordAuthentication no).

August 1st, 2005, 09:46
FreeBSD has sshd in the base and it works out of the box if you enable it in your /etc/rc.conf.

Did you install it manually or from a port or is this the default install? What changes did you make to the config file if it's the stock one?

August 1st, 2005, 11:30
i don't understand it, but it only seems to be from a specific host that I get that error message. I was able to get to another host and ssh from it and got in.

thanks all! i did do a default install, not from ports.

August 1st, 2005, 13:54
dooh forgot to mention the file :D

it is the private key file on the client witch i'm talking about :D