August 1st, 2005, 12:10
I've got 768MB RAM, the mobo is an ABIT with 4 IDE interfaces, 2 are regular IDE and 2 are the faster ones (Ultra IDE?).

Anyhow, the installation is terribly slow, someone had mentionned bus mastering is disabled and that would be the cause of it, could that be the issue?

August 1st, 2005, 13:16
How slow is slow?

Hints: If you install a CDROM drive (or DVD) on the same IDE cable as an EIDE (ie fast IDE) hard disk, then you will have a lot of bus contention and your throughput will be reduced quite a bit. You should always separate hard drives and slower periphs onto their own cables. Also, if your IDE drive is capable of 100 or 133 Mbytes/sec xfer but the ABIT onboard IDE's aren't, then consider getting a plug-in IDE interface card, like a Promise card.

August 1st, 2005, 13:20
Another reason might be the 5.x series switched over to bzip2ing all files, as opposed to the 4.x series which used gzip. Bzip2 offers better compression, however it will take a long time to unpack the files. Just a thought, unfortunatly there really isnt a way around this to my knowledge.

August 1st, 2005, 13:47
slow as in slow like molasses! 7.6KB/sec slow. my CDROM is on its own port?/slot/channel. i've got 2 CDROMs and 2 HDDs, grouped together like you suggested, i'm thinking it could be the cable? is it because i'm using an 80pin cable and not 40pin?

i'm gonna go through my BIOS to check the bus mastering setting.

i had Windows 2000 Pro and Windows 98 installed previously on that box and it was never that slow.

August 1st, 2005, 21:40
80-pin cable should be fine. Oh, you know what: maybe not! If the controller thinks that the bus can go fast it will inform the driver and attempt to crank up the rate. You may be seeing the result of multiple errors and retries. Try using 40-pin cables on the CD drives.

There's been a persistant bug in FreeBSD 5.x installers that caused installs to slow down to a crawl and usually fail outright. That bug always bites me with an IBM laptop. It is fixed by telling the ATAPI driver to not use DMA during install. I thought that they set that mode by default now after so many bugs were logged during the 5.4 beta testing period. I can't find the notes on that now, but there's stuff in the Errata or Release notes for the various releases. See: http://www.freebsd.org/releases/5.4R/installation-i386.html#AEN844 (near bottom).

August 3rd, 2005, 22:10
You might want to try disabling acpi. From the install it's just a matter of picking the 'disable' selection from the opening menu.