September 19th, 2005, 12:17
Hey all!

I've got a Xerox Phaser 6100 sitting on my network that I'd love to print directly to, as opposed to bouncing everything off my XP box. It came with a linux driver that is supposed to work with cups (in fact, i can find the ppd file and so on) and has a nice GUI that I wonder if I can get running under FreeBSD. I've got linux compat running, and I wonder if it's just a matter of letting it rip and see what happens, or should I tread lightly, or is all hope lost and I should just grab the ppd? Any help grandly appreciated!

September 19th, 2005, 13:34
We have some Xerox Phasers ( 77xx series) at work and they are great printers. We had an 850 too until someone decided to keep running labels through it even though the output was missing labels (wonder where they went? :silly: ). They have a webserver that you can upload files to be printed but I doubt that's what you meant by "directly". :biggrin:

Ours have lpd, ipp and jetdirect ports enabled and I imagine the 6100 would too. This gives you a lot of flexibility to printing to these printers. I've read that you can print via CUPS but the quality isn't quite as good since it uses a propriatary GDI interface. Seems like you should be able to get it going and hopefully the quality is still good enough for what you want.

September 22nd, 2005, 11:32
Well, I logged on to my printers little private webserver, and indeed, it claims to not only know, but enjoy lpr. I've followed the handbook, but I'm still not getting any love. :0/ The files go to and disappear from the spool directory, but nothing happens on the printery end. In my hosts file I've added Xerox (which is also the name I've given the printer in the tcp setup dialog at that end) and in my printcap I've tried both

And I've got lpd running, I've run lpc and done start Xerox.
Am I missing something? I think I've done everything in the handbook.

September 22nd, 2005, 12:06
Pleeb, rp= has to be the name of the "remote queue". You need to check the Xerox specs to see what the printer itself expects there. Many printers expect that name to be "text" or "postscript" which controls how it handles the stuff coming at it.

By the way, enable verbose logging in lpd when you start it. Eg:

lpd -c -l

(that's a lower-case ell.)

Or put this in your /etc/rc.conf for boot-time ...

lpd_flags="-c -l"

And enable any logging options in the Xerox printer that it has. There should be an option to spit out an error page if something happens with Postscript.