October 21st, 2005, 14:04
The system beep on my laptop is too loud. http://screamingelectron.org/forum/images/smilies/mad.gif
Is there a way to disable it? Running OpenBSD3.7.


October 21st, 2005, 20:41
If this is under X11 (eg fluxbox), then check out xset ... b The b option controls bell volume, pitch and duration. This
option accepts up to three numerical parameters, a preceding
dash(-), or a 'on/off' flag. If no parameters are given, or
the 'on' flag is used, the system defaults will be used. If
the dash or 'off' are given, the bell will be turned off. If
only one numerical parameter is given, the bell volume will be
set to that value, as a percentage of its maximum. Likewise,
the second numerical parameter specifies the bell pitch, in
hertz, and the third numerical parameter specifies the duration
in milliseconds. Note that not all hardware can vary the bell
characteristics. The X server will set the characteristics of
the bell as closely as it can to the user's specifications.

If this is just from the shell that you mean, well you could rebuild the kernel with the speaker driver removed. :-)

October 22nd, 2005, 05:44
Thanks bmw, xset resolved the problem.
I added the following live to /etc/X11/xdm/Xsetup_0:

/usr/X11R6/bin/xset b off

Thanks again.http://screamingelectron.org/forum/images/smilies/icon_smile.gif