November 25th, 2005, 12:12

I have a problem with a missing /dev/wd0k device.

My system has one disk with the following partitions:

#: id start: end:
0 01 63: 4192902 DOS FAT-12
1 17 4192965: 20482875 OS/2 hidden
2 17 24675840: 20498940 OS/2 hidden
3 A6 45174780: 17318070 OpenBSD

Basically I use GAG and have four options:
P0. MS-DOS 6.2 (for Real Mode Assembly Messing)
P1. Windows 2000
P2. Windows 2000 Image
P3. OpenBSD3.8

I have used this setup with no problems. After Windows 2000 has been fully installed and updated on partition 1, I then make an image of it on partiton 2. I know this is wasteful but it saves time when I want a fresh copy of Windows.

To make the backup I log into OpenBSD and type the following:

dd bs=10m < /dev/wd0j > /dev/wd0k

All this has previously work.

The OpenBSD labels:

#: size offset:
a: 13221495 45174780 [/]
b: 4096575 58396275 [swap]
c: 62506080 0
i: 4192902 63 unknown [MS-DOS]
j: 20482875 4192965 unknown [Win2K]
k: 20498940 24675840 unknown [Win2K Image]

Today I have (unfortunately) had to start from scratch. All went well except when I tried to run the dd command as above. OpenBSD reported /dev/wd0k did not exist!

I then ran the OpenBSD CD-ROM.
The partitions were all listed as above, but when I went to the label, for some reason the following was not present:

k: 20498940 24675840 unknown [Win2K Image]

So my question is, does anyone know why it is missing and more importantly how I can add /dev/wd0k?

November 25th, 2005, 12:36
To try and clarify:






--------------------Where is this?
--------------------and how do I add it?

I can see part of problem from diagram.
Windows 2K is definitely on the first partition [1]. So where the ???????? are this should be labeled J: and J: should be k: if you see what I mean! Any help/suggestions appreciated:

November 25th, 2005, 13:05
So I have this:

# disklabel wd0
# Inside MBR partition 3: type A6 start 45174780 size 17318070
# /dev/rwd0c:
type: ESDI
disk: ESDI/IDE disk
label: IBM-DJSA-232
bytes/sector: 512
sectors/track: 63
tracks/cylinder: 16
sectors/cylinder: 1008
cylinders: 16383
total sectors: 62506080
rpm: 3600
interleave: 1
trackskew: 0
cylinderskew: 0
headswitch: 0 # microseconds
track-to-track seek: 0 # microseconds
drivedata: 0

16 partitions:
# size offset fstype [fsize bsize cpg]
a: 13221495 45174780 4.2BSD 2048 16384 328 # Cyl 44816*- 57932*
b: 4096575 58396275 swap # Cyl 57932*- 61996*
c: 62506080 0 unused 0 0 # Cyl 0 - 62009
i: 4192902 63 MSDOS # Cyl 0*- 4159*
j: 20498940 24675840 unknown # Cyl 24480 - 44816*

I need this to be:

j: 20482875 4192965 unknown
k: 20498940 24675840 unknown

I.e. current j: becomes k: and add new j:
I have no idea how though :frown:. Tried:

# disklabel -w /dev/wd0k
disklabel: /dev/wd0k: Device not configured

November 25th, 2005, 21:17
From your last disklabel read-out, I'm seeing 20,000,000 blocks not even being used. I'm guessing this is where you would want to add your partition. Looks like you need to use 2K, and make another partition with the empty space. Once you make the new one with 2K, it should show in disklabel as k, like you are use to.

November 26th, 2005, 10:45
Yes that it basically what I had to do. Hide all other partitions then start an install in W2K. Wait for format to complete then back in BSD it sees k. Did'nt release it worked that way.

I thought there may have been a way to define the empty space as k without actually having to create fs etc. Oh well. All working now.:icon_smil

November 26th, 2005, 14:16
You can, but since you wanted what looked like a NTFS partition, it didn't act as the best answer for your solution.