January 15th, 2006, 14:28
I picked up a SPARCstation 20 with 3 NICs in it for nothing...seemed like a perfect pf box. I've downloaded the bootable CD for 3.8/sparc and am able to boot from the CD without any problems. All the hardware is found, and the installation goes as you would expect it to.

The first thing that raises my eyebrows is the "Making all device nodes" (I think that's what it says) takes about 5 minutes, then a bunch of scsi-related stuff goes by on the screen before the system restarts. I figured this might be a bad drive, so I swapped it for a known-good drive and had the same results.

When the system tries to boot from the disk, I get the following error:

Boot device: /iommu/sbus/sdpdma@f,400000/esp@f,800000/sd@3,0:a File and args: bsd
The file just loaded does not appear to be executable.

I followed the sparc installation instructions, and so far I have tried the following:

setenv boot-file bsd
setenv boot-device disk0:a
setenv boot-device disk3:a

sometimes I would get a "Can't open boot device" error, which leads me to believe that the boot-device disk3:a is actually correct...seems like there's something wrong with the boot block.

If anybody has seen anything like this and can point me in the right direction, that would be much appreciated.

Thanks in advance.

January 15th, 2006, 16:16
hmm, I havnt played with obsd on a sparc in quite awhile, may have to dig it out of closet and give it a go with 3.8....

January 19th, 2006, 12:28
Well, playing with a SS10, Im not seeing any of the problems you mention here. Not sure whats going on.

January 25th, 2006, 05:06
what boot prom version do you have?


January 31st, 2006, 00:05
Thanks for the responses.

I actually gave up on this machine and used an Ultra1 that I had kicking around instead. I'm not really sure what the problem was with the SS20, but there's only so much effort I'm willing to put into a 50MHz machine.

Thanks again...

February 16th, 2006, 15:38
Sounds like older boot prom not recognizing the kernel.
but I've only seen that when I tried to use new hardware with an older solaris boot cd.