July 18th, 2006, 16:55
Hi All,

I've been trying to get Firefox & Mozilla running on a laptop that origanly had Windows running on it. I compiled, without any errors, both browsers and when I try to start them via CLI I get nothing. No error, nothing but a new promnt. "top" does not show any of the previously metioned browsers are running. Thunderbird had no problems compiling or running. CVSUP was run after I had installed FBSD.

Has anyone else run into this problem either with a mozilla or some other product?
Does anyone have an idea how to fix this?

Xorg Config (http://gerda.univie.ac.at/freebsd-laptops/index.pl?action=show_config&config=xconfig&laptop=1049)
Kernel Config (http://gerda.univie.ac.at/freebsd-laptops/index.pl?action=show_config&config=kernel&laptop=1049)

Output of dmesg:

Copyright (c) 1992-2005 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD 6.0-RELEASE #0: Fri Jul 14 09:03:35 PDT 2006
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Pentium(R) M processor 1300MHz (598.06-MHz 686-class CPU)
Origin = "GenuineIntel" Id = 0x695 Stepping = 5
real memory = 536674304 (511 MB)
avail memory = 515842048 (491 MB)
acpi0: <HP CPQ0860> on motherboard
acpi0: Power Button (fixed)
acpi_ec0: <Embedded Controller: GPE 0x1c> port 0x62,0x66 on acpi0
pci_link0: <ACPI PCI Link C0C2> irq 10 on acpi0
pci_link1: <ACPI PCI Link C0C3> irq 10 on acpi0
pci_link2: <ACPI PCI Link C0C4> irq 5 on acpi0
pci_link3: <ACPI PCI Link C0C5> irq 5 on acpi0
pci_link4: <ACPI PCI Link C0C6> on acpi0
pci_link5: <ACPI PCI Link C0C7> irq 11 on acpi0
pci_link6: <ACPI PCI Link C0C8> on acpi0
pci_link7: <ACPI PCI Link C0C9> irq 5 on acpi0
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_perf0: <ACPI CPU Frequency Control> on cpu0
acpi_perf0: failed in PERF_STATUS attach
device_attach: acpi_perf0 attach returned 6
acpi_perf0: <ACPI CPU Frequency Control> on cpu0
acpi_perf0: failed in PERF_STATUS attach
device_attach: acpi_perf0 attach returned 6
acpi_throttle0: <ACPI CPU Throttling> on cpu0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <Intel 82855 host to AGP bridge> mem 0xb0000000-0xbfffffff at device 0.0 on pci0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
drm0: <ATI Radeon Lf R250 Mobility 9000 M9> port 0x3000-0x30ff mem 0x98000000-0x9fffffff,0x90400000-0x9040ffff irq 10 at device 0.0 on pci1
info: [drm] AGP at 0xb0000000 256MB
info: [drm] Initialized radeon 1.16.0 20050311 on minor 0
uhci0: <Intel 82801DB (ICH4) USB controller USB-A> port 0x48c0-0x48df irq 10 at device 29.0 on pci0
usb0: <Intel 82801DB (ICH4) USB controller USB-A> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <Intel 82801DB (ICH4) USB controller USB-B> port 0x48e0-0x48ff irq 5 at device 29.1 on pci0
usb1: <Intel 82801DB (ICH4) USB controller USB-B> on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: <Intel 82801DB (ICH4) USB controller USB-C> port 0x4c00-0x4c1f irq 5 at device 29.2 on pci0
usb2: <Intel 82801DB (ICH4) USB controller USB-C> on uhci2
usb2: USB revision 1.0
uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
ehci0: <Intel 82801DB/DBL/DBM (ICH4) USB 2.0 controller> mem 0xa0000000-0xa00003ff irq 5 at device 29.7 on pci0
usb3: EHCI version 1.0
usb3: companion controllers, 2 ports each: usb0 usb1 usb2
usb3: <Intel 82801DB/DBL/DBM (ICH4) USB 2.0 controller> on ehci0
usb3: USB revision 2.0
uhub3: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub3: 6 ports with 6 removable, self powered
pcib2: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci2: <ACPI PCI bus> on pcib2
fwohci0: <VIA Fire II (VT6306)> port 0x2400-0x247f mem 0x90200000-0x902007ff irq 10 at device 0.0 on pci2
fwohci0: OHCI version 1.0 (ROM=1)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 00:02:3f:36:38:00:10:a6
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: Link S400, max_rec 1024 bytes.
fwohci0: max_rec 1024 -> 2048
firewire0: <IEEE1394(FireWire) bus> on fwohci0
sbp0: <SBP-2/SCSI over FireWire> on firewire0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:02:3f:00:10:a6
fwe0: Ethernet address: 02:02:3f:00:10:a6
fwe0: if_start running deferred for Giant
fwohci0: Initiate bus reset
fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
re0: <RealTek 8139C+ 10/100BaseTX> port 0x2000-0x20ff mem 0x90300000-0x903000ff irq 10 at device 1.0 on pci2
miibus0: <MII bus> on re0
rlphy0: <RealTek internal media interface> on miibus0
rlphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
re0: Ethernet address: 00:00:00:00:00:00
pci2: <network> at device 2.0 (no driver attached)
cbb0: <ENE CB1410 PCI-CardBus Bridge> mem 0x90100000-0x90100fff irq 5 at device 4.0 on pci2
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH4 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x4c40-0x4c4f irq 5 at device 31.1 on pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
pcm0: <Intel ICH4 (82801DB)> port 0x4000-0x40ff,0x4880-0x48bf mem 0xa0200000-0xa02001ff,0xa0300000-0xa03000ff irq 10 at device 31.5 on pci0
pcm0: <Analog Devices AD1981B AC97 Codec>
pci0: <simple comms, generic modem> at device 31.6 (no driver attached)
battery0: <ACPI Control Method Battery> on acpi0
acpi_acad0: <AC Adapter> on acpi0
acpi_button0: <Power Button> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse, device ID 3
sio0: <Standard PC COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
sio1: <Generic IRDA-compatible device> port 0x3e8-0x3ef,0x7d0-0x7d7 irq 3 drq 3 on acpi0
sio1: type 16550A
ppc0: <ECP parallel printer port> port 0x378-0x37f,0x778-0x77a irq 7 drq 1 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
pmtimer0 on isa0
orm0: <ISA Option ROM> at iomem 0xc0000-0xcffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ums0: B16_b_02 USB-PS/2 Optical Mouse, rev 2.00/98.02, addr 2, iclass 3/1
ums0: 7 buttons and Z dir.
Timecounter "TSC" frequency 598062808 Hz quality 800
Timecounters tick every 1.000 msec
ad0: 57231MB <IC25N060ATMR04 0 MO3OAD0A> at ata0-master UDMA100
acd0: CDRW <QSI CD-RW/DVD-ROM SBW-241/VH04> at ata1-master UDMA33
Trying to mount root from ufs:/dev/ad0s1a
info: [drm] Loading R200 Microcode

Hopefully this will provide enough info. If you need some other info, please let me know. Any help would be appreacted!

Thanks in advance,

July 18th, 2006, 17:08
You might try going back into the port and running:

make deinstall && make reinstall

Sounds like something foobared on the install. Are you trying to run both Mozilla and Firefox? I know at one time they use to overlay each other on some files, but that might not be the case now. Try uninstalling one, and running the other after a reinstall of the port.

July 18th, 2006, 19:46
@ K.K.

I had removed Mozilla but had kept Firefox. I tried your suggestion of make deinstall && make reinstall and Firefox still does the same thing, New promnt but no Firefox. I am not includeing the "&" to run it in the background. I just want to see if it works or not.

Should this be reported to the maintainer of Firefox on FreeBSD? or is this pretty much a localised problem and I'm hosed as far as running Firefox on this thing.

I have never been able to get any of the linux version to run. Its always missing something that I can't seem to find on the ftp server.


July 19th, 2006, 00:34
Wait, you are trying to install the Linux port of Firefox and Mozilla, and not the FreeBSD ported versions?

July 19th, 2006, 11:08
:redface: Heh, no. Sorry. It was the FreeBSD version. I should have been more clear.

For some reason I included that I had never been able to get anything to work with the Linux compat. Looking back I don't know why I put that in.

Thanks for your help K.K.

July 20th, 2006, 19:00
Did you have an older .mozilla directory in your $HOME? If so, possibly something is corrupt in there - all your user data will be in there and if some setting is off it can crash mozilla/firefox. If you have that dir, move it to a different name and try launching the app again. If it still crashes, check if that dir was created again. If it was, at least it gives you an idea of when the app is failing.

Good luck,

July 21st, 2006, 16:35
Oh my god. That worked!
Thanks Frisco!