May 31st, 2003, 15:06
I've tried installing both 5.0 and 5.1 beta 2 and I am getting stuck at the same error which says that the disk geometry does not match up w/ what's reported. I have Googled quite a bit and found other people who had the same error and so far I found two solutions which are : ignore and keep installing ( didn't work) and change the way BIOS sees your hard drive (change to LBS or CHS or auto or large) which also didn't work. I am attempting to install to the 2nd partition on my 2nd drive. There's nothing wrong w/ this box I'm using; Debian, Redhat, and XP all run fine on it. Anybody have any ideas? I apologize if I seem a bit confused. This FreeBSD install attempt and my OpenBSd firewall ( not fully functioning) are my first forays in the BSD world. Make me a convert!

May 31st, 2003, 20:26
Almost seems like a hardware issue, but I could be very wrong. You might try setting the drive manually in the BIOS to AUTO:AUTO, and see what spits out. Sound like you've tried all the options in the BIOS. You might see if the Virus Protection in the BIOS is on, and try it with it off. Also, when setting it up, did you replace the MBR, or leave it alone? Might try replacing the MBR if you haven't either. Another thing might be to manually fdisk the drive, and start with a clean partition table. Other than that, all I can say is double check your HDD Cyl, Heads, Sector settings, or try out 4.8 (IMO it is better than 5.x).

BTW, love the avatar!!!!!!!!

"Don't worry, they're just nihilists." :wink:

May 31st, 2003, 21:18
Free 5 is very impressive. Blows 4.x out of the water easily in my opinion. I've got two or three installs now and haven't had a single glitch with any.

My guess is that your trouble is coming from incorrectly setting up the slices when you're installing FBSD. Either that or one of your partitions is pushing the envelope of being hosed... I'd suspect XP as I saw this happen on my XP box as well and couldn't resolve it until I wiped everything.

How are you setting up your disks for the install partitions and slices included?

June 1st, 2003, 15:01
Well here's what happens. I boot off of either the 5.0 or 5.1 Beta 2 CD and sysinstall pops up. I choose ad1 as the drive I want to install to. The message "WARNING " A geometry of 159560/16/63 for ad1 is incorrect." I hit OK and drive on to the FDISK Partition Editor. I note that the disk geometry at the top of the screen is EXACTLY what BIOS says it is (10011cyls/255 heads/ 63 sectors). I hit G to enter the proper geometry and see the right info is there so I enter that just to make sure. That goes fine. I see the roughly 10 gig partition I want to install FreeBSD on which is 2 of 2 parttions on the disk and it's reported as :
Offset Size(ST) End Name PType Desc
160826715 9765 160836479 - 12 unused
Subtype Flags
So I highlight the partition I mentioned above, click C for Create Slice and see the size as 9765 which seems to be right and hit OK. Then I enter 165 as the partition type FreeBSD and hit enter. Now I see the following new entry on the screen.

Offset Size(ST) End Name PType Des Subtype
160826715 0 160826714 ad1s1 8 freebsd 165

What am I missing here? This is where I get stumped. I don't install a FreeBSD MBR since I'm using Grub already, I get to Disklabel Editor and it says that I'm on Disk ad1, partition name ad1s1 and there's 0 free blocks so I can't do anything.

June 1st, 2003, 22:46
Any ideas?

June 1st, 2003, 23:35
On the first partition screen I assume you are using all, and then continuing. On the next screen you are creating your slices? Just had to check. :P

What happens when you let it automatically configure the slices?

June 2nd, 2003, 00:12
No, I'm trying to use that 10 (roughly) gig partition which is the last partition on the 2nd drive.

June 2nd, 2003, 01:14
What else is on that drive?

FreeBSD doesn't like being after extended patitions

June 2nd, 2003, 01:16
It's just a FAT32 partition that I use for storage between OSs'.