June 3rd, 2003, 19:22
I am looking to add to my new Postfix/Courier-Imap mailserver. At this time I am the only user on it. I would like to add 'bill, bob and sue' for example. Same domain name but different users. I assume that i must create user accounts on FreeBSD for them...or not? They will access their mail by webmail maybe or by an imap client.
Can someone give me an outline of how to do this. I have read a lot of docs, all over my head at this time.

Thanks for the input!!

June 4th, 2003, 09:55
you can always use aliases to point to the actual system account... or you could also possible set it up to use mysql tables.. not too sure on how that works though been meaning to play around w/ that...

June 4th, 2003, 12:03
Believe it or not, the setup for what you're after is quite simple. If you follow elmore's how-to on setting up postfix you'll have a fully functional SMTP/MTA in no time.

Then for IMAP, courier is easy to setup on FreeBSD. Install it from ports, create a self signed ssl certificate so you can use imap-ssl and start it up with the rc scripts.

Then for users, indeed your best bet is to create local user accounts. You can do this easily via adduser.

Start sifting through the above and let us know when/where you get stuck!

June 4th, 2003, 12:27
I already have the server being used...in its default state, including Courier-Imap. I havent a clue about how to set a signed SSL certificate. Once again, everything I have read is over my head. I have not done this before so am looking for some straight forward instructions. I guess the SSl should be my next step.

"aliases-mysql tables"...havent a clue about them at all. Once again, this is my first experience with any type mailserver.

June 4th, 2003, 13:13
inside the howto section is a document elnore wrote up and did a great job on it.. that talks about setting up a mailserver.. just read when he has to say and you should not have any problems...

and here's my rendition of it:

June 4th, 2003, 15:11

The next file we'll be looking at is /etc/postfix/body_checks. This file is either a regex file or a pcre file (if you compiled postfix with pcre support) I mainly use this file to block troublesome attachments I have no use for anyways. The following blocks certain types of attachments. Self explanatory.

"/^(.*)name="(.*). (com|vbs|vbe|js|jse|exe|bat|cmd|vxd|scr|hlp|swf|mp eg|mpg|mov|mp3|avi|pif|mpe|shs|ini)"$/ REJECT"

This will help out with viruses among other things, you won't have to worry about vbs scripts and that sort of stupid thing from now on. This file just needs to be in place. There is NO need to make it a hashed db. Although after making changes DO reload postfix!

For example, I am told that I need to add the above to the file 'body_checks'. I dont have a file 'body_checks'. I assume I must create one....huh? Then it says that the file is either a regex file or a pcre file. That means absolutely nothing to me....how do I get around this? Do I just create the 'body_checks' file with no extension or does it being a regex file mean I have to have an extension on it? I tried just creating a simple 'body_checks' file, added that in it and added body_checks = regexp:/etc/postfix/body_checks to my main.cf....nothing, those listed attachments still get through.

See what I mean...not very clear for a first timer.

June 4th, 2003, 15:25
did you run postmap body_checks after creating one? since you have the regexp in your main.cf your required to have a body_checks file. and postfix wants your stuff to be hashed...

June 4th, 2003, 15:35
Shouldn't need to be postmaped as it's a regexp file. You do need reload postfix after any config changes:

postfix reload

June 4th, 2003, 16:00
I add this: body_checks=regexp:/etc/postfix/body_checks to my main.cf

I create /etc/postfix/body_checks I then add:
/^(.*)name="(.*). (pdf|com|vbs|vbe|js|jse|exe|bat|cmd|vxd|scr|hlp|sw f|mpeg|mpg|mov|mp3|avi|pif|mpe|shs|ini)"$/ REJECT

I then postfix reload.

I have someone send me a .pdf and it comes through...why?

June 4th, 2003, 16:47
Shouldn't need to be postmaped as it's a regexp file.

postfix reload

glad to know.,... thx.