June 10th, 2003, 18:35
I Have configured an OpenBSD 3.3 bridge with 3 network interfaces in the bridge configuration.
The bridge works fine, but one problem appears when i put my pf on.

Some customers are complaining about connectivity problems. My firewall logs nothing. Customers (http users) report (Yes, that lousy default Internet Exploder error message, sorry i don't have more information) that there is an "dns or server error".

* I have tried to disable TCP options flags, but that didn't solve my problem
* I have tried to set a larger timeout for tcp.established. That did not help.
* I have rewritten my whole pf.conf, made it on a totally different way, still that doesn't help.

My pf.conf :

What could be the cause of this?

June 11th, 2003, 13:26
Sorry, I don't run a bridge... Kinda surprised no one else has answered yet, as elmore runs a bridge and possibly some others around here...

June 11th, 2003, 14:10
Sorry been busy lately I plan on posting up some stuff, just haven't got to it yet. Sorry gryp :(

June 11th, 2003, 14:56
NP, i can't force you guys to do it ASAP (-:

As long as my big problem gets solved :(

June 11th, 2003, 15:15
We'll get it resolved for sure. :)

June 25th, 2003, 15:44
Well, it's the 25th and I still haven't had time to look at this, I apologize gryp. I've been travelling quite a bit as of late so I haven't been around. Anyone want to give this one a go?

June 25th, 2003, 17:43
I mailed to pf@ and i got an answer from Daniel Hartmeier.

He told me to change different things, Still i get some bad states.

The thread :

June 25th, 2003, 18:50
awesome, some feedback right from the source. Can't get much more authoritative than that! :)

Well gryp I'm sorry we couldn't help you out but I'm glad that you got an answer, and that you posted the reference. Thanks :)

July 1st, 2003, 20:30
Well actually my problem isn't fixed yet, i just posted a new mail to pf@.
We are getting there, bit by bit. very slow.

here's the thread online: