July 1st, 2003, 17:14
Hello all

I have an old Dell Latitude CPi D266XT laptop that I've been playing around with for a few months. Its currently running FreeBSD 5.1 Release, I just upgraded it from 5.0 last week. Everything is running good and I even managed to get ACPI to work but it doesn't detect the sound card. The card is a Crystal Sound 4237b and is listed as being supported by pcm in the man page. The kernel has been recompiled with both the pcm and csa drivers.

I've been digging and digging for answers but so far have come up with only dead ends. Most people say that PNP OS needs to be disabled in the BIOS, but my BIOS doesn't have that problem. The FreeBSD hand book suggests to add options PNPBIOS to the kernel config but when I run it through config it comes back telling me that is an invalid option. I assume that section of the handbook is pre version 5. I've tryed various configurations that others have said worked in 4.8 to no avail.


Here's the dmesg:
FreeBSD 5.1-RELEASE #2: Tue Jul 1 03:10:23 EDT 2003
Preloaded elf kernel "/boot/kernel/kernel" at 0xc0746000.
Preloaded acpi_dsdt "/boot/acpi_dsdt.aml" at 0xc07461f4.
Preloaded elf module "/boot/kernel/acpi.ko" at 0xc074623c.
Timecounter "i8254" frequency 1193182 Hz
Timecounter "TSC" frequency 267274545 Hz
CPU: Pentium II/Pentium II Xeon/Celeron (267.27-MHz 686-class CPU)
Origin = "GenuineIntel" Id = 0x652 Stepping = 2
real memory = 67043328 (63 MB)
avail memory = 57319424 (54 MB)
Pentium Pro MTRR support enabled
ACPI: DSDT was overridden.
ACPI-0375: *** Info: Table [DSDT] replaced by host OS
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <DELL CPi > on motherboard
pcibios: BIOS version 2.10
Using $PIR table, 5 entries at 0xc00fb940
Timecounter "ACPI-safe" frequency 3579545 Hz
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
acpi_cpu0: <CPU> port 0x530-0x537 on acpi0
acpi_tz0: <thermal zone> port 0x530-0x537 on acpi0
acpi_acad0: <AC adapter> on acpi0
acpi_cmbat0: <Control method Battery> on acpi0
acpi_cmbat1: <Control method Battery> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_button0: <Power Button> on acpi0
acpi_button1: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pci0: <display, VGA> at device 2.0 (no driver attached)
cbb0: <TI1131 PCI-CardBus Bridge> at device 3.0 on pci0
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
pcib0: slot 3 INTA is routed to irq 11
cbb1: <TI1131 PCI-CardBus Bridge> at device 3.1 on pci0
cardbus1: <CardBus bus> on cbb1
pccard1: <16-bit PCCard bus> on cbb1
pcib0: slot 3 INTB is routed to irq 11
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel PIIX4 UDMA33 controller> port 0x860-0x86f at device 7.1 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
uhci0: <Intel 82371AB/EB (PIIX4) USB controller> port 0xece0-0xecff irq 11 at device 7.2 on pci0
usb0: <Intel 82371AB/EB (PIIX4) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
pci0: <bridge, PCI-unknown> at device 7.3 (no driver attached)
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model Generic PS/2 mouse, device ID 0
fdc0: <Enhanced floppy controller (i82077, NE72065 or clone)> port 0x3f7,0x3f2-0x3f5 irq 6 drq 2 on acpi0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
sio0 port 0x3f8-0x3ff irq 4 on acpi0
sio0: type 16550A
sio1 port 0x290-0x297,0x3e8-0x3ef drq 3 on acpi0
sio1: type 16550A
ppc0 port 0x778-0x77b,0x378-0x37f irq 7 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
orm0: <Option ROM> at iomem 0xc0000-0xcbfff on isa0
pmtimer0 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounters tick every 10.000 msec
ep0: <3Com Corporation 3C589D> at port 0x100-0x10f irq 11 function 0 config 1 on pccard0
ep0: Ethernet address 00:60:08:ec:aa:86
ad0: 6194MB <IBM-DADA-26480> [13424/15/63] at ata0-master UDMA33
acd0: CDROM <SAMSUNG CD-ROM SN-124> at ata1-master PIO4
Mounting root from ufs:/dev/ad0s1a

July 1st, 2003, 23:25
Hmmm... no suggestions as yet, however, looks like you're not the only one with that problem:


July 3rd, 2003, 16:13
For your laptop I think you have to add either

device sbc


device pcm
device sbc0 at isa? port 0x220 irq 5 drq 1 flags 0x15 (with your settings)

depending on weather or not it's pnp.
(from http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/sound-setup.html)

for isa (from |MiNi0n|'s post, http://news.gw.com/freebsd.hardware/3146, "This card is connected to the
ISA bus at, I believe, io=0x530, irq=5, drq=1. Pnpinfo does not show any
plug-n-pray devices but I am not sure whether this is a PNP card or not.")

This guy: http://www.geocrawler.com/archives/3/151/2002/2/0/7974272/ has your same laptop and needs the extra lines in his kernel config. But he's on old BSD so I'm not sure if that makes a difference.

I had this problem too, but mine was a simple fix. I had to recompile my kernel like 20 times to compile without erroring out. By the end of it I was confused and frustrated and had forgotten to do 'make install' before rebooting, so it was pointing to the wrong kernel.

I hope that helps. If you tried that or if I've misunderstood entirely I apologize.


July 8th, 2003, 12:50
P-chan did this get worked out for you?

BTW welcome p-chan and bk! Nice to see two new faces! :)

July 9th, 2003, 17:35
I had tryed compiling the kernel with sbc in before with no luck. I just tryed to do it again with:
device sbc0 at isa? port 0x220 irq 5 drq 1 flags 0x15
device sbc0 at isa? port 0x530 irq 5 drq 1 flags 0x15
I has also tryed that with device csa0.

When I run config it says that that a device with zero units is most likely misconfigured or something to that extent. I also tryed compiling it with sbc and putting those settings in /boot/device.hints. So far no change.


July 16th, 2003, 03:27
"From BSD Handbook" ~Multimedia~ Crystal Sound Cards "this includes the 4237" Worked for my 4239.

For Crystal cards, you will need to add:

device pcm
device csa

to your kernel configuration file.

cd /usr/src
echo "device csa" >> sys/i386/conf/GENERIC
make buildkernel KERNCONF=GENERIC
make installkernel KERNCONF=GENERIC

Repeat for "device pcm" and possibly "device sbc" - my card is isa. For laptop I don't know about this.

Reboot then as "root"
cd /dev
sh MAKEDEV snd0

This got my sound going with Crystal Card 4239. In 4.8 and 5.1

Hope this helps.

Regards and Good Luck!

July 19th, 2003, 18:28
I currently have pcm csa and sbc all compiled into the kernel and have tryed various combinations of them before. There is no file called MAKEDEV on the system, when I was reading through the faq they made it sound like makedev wasn't used in version 5 or later.