July 14th, 2003, 16:56
So....tell me....how do I play a CD and rip MP3's. Maybe I should say what can I find in porrts that would be recommended to do so? Nothing too fancy....basic is good.

July 14th, 2003, 17:57
CD player try xmms (http://www.xmms.org), pkg_add -r xmms, or cd /usr/ports.multimedia.xmms && make && make install.

As for ripping Compact Discs try, grip (http://nostatic.org/grip/), pkg_add -r grip, or cd /usr/ports/audio/grip && make && make install.

You may also like to have video playback in which case install, mplayer (http://www.mplayerhq.hu/homepage/design6/news.html), cd /usr/ports/multimedia/mplayer && make && make install.

July 14th, 2003, 18:03
Didnt know XMMS play CD's as well. I currently use that for MP3's. :)

I'll check out grip too...thanks!

July 14th, 2003, 18:28
Arrrghhh-----justs keep getting better!

How do I play a cd now with XMMS? I stick a CD in and my /cdrom is blank.
I can mount cd's fine but cant get an audio cd to be noticed.

July 15th, 2003, 11:14
Stick in your CD. Do not mount it. In xmms go to Play Directory (right click for the menu). Choose the /cdrom directory. xmms will automagically pick up your CD and start to play it.


July 15th, 2003, 11:36
Ummm....nope, doesnt do it. Grip doesnt recognize anything in my drive either. I do have a music CD in there and I can mount regular CD's. Grip is using /dev/cdrom and in my dmesg I have: acd0: CDROM <Lite-On LTN486S 48x Max> at ata1-master PIO4

July 15th, 2003, 12:46
To play a cd under XMMS, simply start xmms got to the playlist editor and add dir /cdrom( or whatever directory you use for your /dev/acd0 ).

As for grip create a symbolic link to acd0, I don't know why grip is so linux dependent :roll:.
cd /dev
ln -s acd0 cdrom

Hope that helps :).

July 15th, 2003, 13:39
When I add acd0, grip locks up. When I try to add files or the dir in XMMS...there is nothing showing to add...in the directory. It is like it is not even reading the CDROM.

July 15th, 2003, 16:05
Make sure you have the cdplayer plugin loaded in xmms or your cdplayer won't play. Make sure /dec/acd0 is linked to /dev/cdrom

July 15th, 2003, 20:28
It is ......still nothing. I cant see anything by going to /cdrom in a terminal either.

July 15th, 2003, 20:52
check your fstab configuration make sure that you have a line in there that reads

/dev/acd0 /cdrom cd9660 ro,noauto 0 0

also make sure that you have created a symbolic link between /dev/acd0 and /dev/cdrom. Usually you wont need to mount the cdrom just run xmms->add->dir->/cdrom and off you go playing your songs. Also grip should automaticly detect your cd.

July 15th, 2003, 21:01
/dev/acd0c /cdrom cd9660 ro,noauto 0 0
is what is in my fstab.

I tried xmms with the above, still nothing.
In xmms I have:

device: /dev/acd0c
directory: /cdrom

A symlink....I have needed one before....why now?

July 15th, 2003, 21:10
A symlink....I have needed one before....why now?

GRIP searches your system for /dev/cdrom, most likely your system does not have such entry under /dev/. There are two ways around this the first is specify the device with the --device flag for instance

grip --device=/dev/acd0

The second way is too fake the entry by creating a symbolic link to /dev/acd0.

ln -s /dev/acd0 /dev/cdrom

Xmms try changing the /dev/acd0c to /dev/acd0. Also if you have even futher problems isntall XCDROAST that might be alot more intuitive than grip ....

July 15th, 2003, 21:17
$ grip --device=/dev/acd0
Error: Unable to initialize [/dev/acd0]

I do have a /dev/cdrom

Where do I put the symlink to /dev/acd0?

Here is what else I found out. If su and run xmms it finds the /cdrom and lists the songs on the CD. I play it and it will play but with no audio. FIrst...why only root and of course why cant I hear it? This is extrememly odd, I have 2- Freebsd 4.8 machines that this happens on. I have a 5.0 machine and it works will no fussing.....this doesnt add up to me.

July 16th, 2003, 01:39
On mine, to play a CD on XMMS, or to rip from Grip, I have to be root. Did you try that?

July 16th, 2003, 03:29
Yes, it will play as root....but there is no audio. That aint right.....why would a user need be root to play a CD?

July 16th, 2003, 09:13
your cdrom symlink should have 666 permissions... it probbibly doesnt have permissions for regular users

July 16th, 2003, 11:39
Ok....tell me where to put this symlink. Do I want to do it in /dev/cdrom and have it
ln -s /dev/acd0 with 666 permissions?

July 19th, 2003, 11:57
I have been trying this on 4.8-R too.

So I did a,

#ln -s /dev/acd0 /dev/cdrom
#chmod 666 /dev/cdrom

Try to load /cdrom in xmms no files

#chmod 777 /dev/cdrom

tried loading /cdrom in xmms and still no music. Any other ideas? Maybe need a chmod to /cdrom?

July 19th, 2003, 12:07
Do you guys have the audio cable connected from the soundcard to the cdrom drive?

Also, many times audio can be enabled, but the mixer settings may be set all the way down.

July 19th, 2003, 12:34
Finding this annoying.....and unlikely, I unearthed this Dell machine from its hole. I bought this machine new a little while ago, in a sealed box from Dell. There is no cable from the CD to the soundcard....what gives!! Maybe I didnt pay enough for the machine to warrnant playing music CD's.

July 19th, 2003, 12:51
This is on a laptop for me. No audio cable and the sound already works, I can do this as root but I don't want to login as root all the time just to play cd's.

July 19th, 2003, 13:06
Got it ! :D First I didn't have a /dev/acd0 only a /dev/acd0c and /dev/acd0a. So I,

#ln -s /dev/acd0c /dev/cdrom

then I tried to chmod the new symlink

#chmod 666 /dev/cdrom

It still wouldn't take the chmod though so I did a

#chmod 777 /dev/acd0c

and now xmms will play cd's!! LIttle overkill to 777 the acd0c so I am gonna play with it and see what permissions it needs to play cd's


Ok acd0c (or whatever device your cd player is) needs to have read permissions added for others, so a

#chmod o+r /dev/acd0c


#chmod 644 /dev/acd0c