July 17th, 2003, 21:46
Hey guys. Been having a good run on my 4.8 installation before I noticed that my system (set to EST [EDT?]) thinks that it is now 9am rather than 9pm. I used the /stand/sysinstall utility and set it to what was my specific timezone and then, to test, just the generic EST setting. Both show the same time which is sort of correct except that am is confused with pm. I hope this is not too basic a question but does anyone know what is going on here or how to fix it? So far when I've been stumped this has been the place to come for answers. Thanks for any help anyone can provide.

July 17th, 2003, 23:27
This is an annoying problem when you run into it and don't know quite how to fix it. There's good news though because it's pretty easy to take care of. Type date to see the current date and time. You can also use date to change the date and time.

Read up on the man page for date e.g. (man date) or read it online

date 2030 would set your time to 8:30pm since it uses 24hour format.

I hope this helps out. :wink:

July 18th, 2003, 09:19
i've ran into that problem before...

trying to remember how i fixed it...

you should have a


the system symlinks the zone info from there to another location and thats how the system knows what zone to use..

i cant remember where it puts it though.. sysinstall i've always had problems with...

EST was always a couple hours off for me so i started using EDT then i use rdate on a cron job to update w/ a time server.. this seems to work for me but might not for you... good luck hope this info helps..

July 19th, 2003, 10:28
Thanks guys. I ran the date command and corrected the date and time on my system. Sorry to bug you guys with a question that turned out to have a simple solution.

July 19th, 2003, 16:05
ummm, you didn;t bug us, that's what we're here for :!:

Glad we could help :D

July 24th, 2003, 13:07
i remember now how to set the timezones manually

"rm /etc/localtime"
"ln -s /usr/share/zoneinfo/TIMEUWANT /etc/localtime"