July 25th, 2003, 18:28
Has anyone managed to get this to work?

I'm using an IBM wavelan silver pc card, its some how involved in that lucent/orinoco/agere lineage. Primary firmware 4.00, Station firmware 8.72. I'm using 5.1 release and bsd-airtools was compiled from my local ports tree that I installed with the os.

When I start dstumbler I get this error: unable to ioctl device socket: Input/output error.

The bsd-airtools site says something about having to patch the wi driver. The patches are for 4.4 and I'd assume it wouldn't be a good idea to run them on my system.

I found these patches in the freebsd-moble archive:
http://docs.freebsd.org/cgi/getmsg.cgi?fetch=112789+0+archive/2003/freebsd-mobile/20030629.freebsd-mobile http://docs.freebsd.org/cgi/getmsg.cgi?fetch=201133+0+archive/2003/freebsd-mobile/20030629.freebsd-mobile
They both completely fail when I try to apply them though.

Maybe I should trying going to current but I'm a little afraid since I have everything pretty much working now (except the sound) that I'll mess it up. Well that and the fact that I'm not really sure what I'm doing.


July 25th, 2003, 20:42
I have yet to find anyone who has made dstumbler work in 5.x. Some have done so much, they ended up moving to 4.8. Probably have to wait for Dachb0den Labs to make a 5.x version. :?

This is the main reason I'm sticking to 4.8 for the time being.

July 26th, 2003, 00:57
hmm... I made a set of 4.8 disks a while ago so I guess I'll give it a shot. What I really like about 5.x is kde 3.x but I'd assume I can get that to run on 4.8 just fine. From what I've read I'd also stand a better chance of getting my sound to work. I've got a couple extra laptop hard drives around so I guess I'll give 4.8 a shot. Any tips for getting it to work in 4.8?


July 26th, 2003, 13:41
Dstumbler won't be a problem at all in 4.8, neither should your sound card. Just compile with 'device pcm', and all should be good. As for dstumbler, an easy line of 'dstumbler wi0 -o' should get you surfing right away.

NOTE: wi0 is just an example of a device. Yours might be different.

August 2nd, 2003, 00:46
I've the laptop running on 4.8 now and I've been farting around with it on and off for a week or so trying to make things work. I've got dstumbler on and it "works", but it won't run in monitor mode. The card is a lucent wave lan based (orinoco) and I assume that the drivers need to be patched. The script they give to apply the patches doesn't work. Would it be a good idea for me to just manually apply the patches for the drivers or is there a better way? I've only been half-assed seaching on this in my spare time as I've been rather busy with job related things.


August 2nd, 2003, 11:40
How did you execute dstumbler? Did you do 'dstubler -i wi0 -o' ?

August 2nd, 2003, 23:59
dstumbler wi0 -o


August 3rd, 2003, 00:15
A friend of mine also uses a Linksys WaveLAN, but not sure what version. Anyways, he seems to get away with just using 'dstumbler wi0'. Have you tried messing with 'prism2ctl' yet?

August 3rd, 2003, 01:56
I tryed it with out -o, it runs but doesn't pick anything up. I let it sit for 5 minutes in the presence of one of those netgear wireless cable/dsl routers running the default config and it didn't pickup a thing. Prism2ctl doesn't seem to like the card, gives me either an i/o error or no output depending on what args I give it.
I just fired it up at home and turned on the card in my win2k box and it picked that right up. Its a d-link card running in adhoc in I use it for my ghettoed home wireless so I guess its sort of working. I'd forgot I had it turned off (on a related note, any tips on updating the firmware on a d-link dwl-520 prisim2 based pci card? I've tryed many diferent versions of winupdate and drivers on it with no luck. I'd like to stop it from broadcasting the ssid).

Any ideas on why it didn't see the netgear? I'll give it another shot when I'm back in the office on monday.


August 3rd, 2003, 15:07
Are you using 2 computers, or is one an access point? I'm not sure that dstumbler works in ad-hoc mode. You might switch to BSS mode, I try then. If you are running for more than one connection, then you should use BSS mode. I take it that you can get a connection with it at least?

August 4th, 2003, 00:37
It did work on the adhoc network I have at home. It did not work on the base station we have at work. I can't use bss mode on the card I have at home. I have to upgrade the firmware first and I can't find an upgrade util that will work. I could get a connection to the base station at work, the one that it didnt detect. I can't connect to the adhoc network at home. I attribute that to the fact I've had 30 diferent drivers on that card in the past week trying to find one that will let the upgrade util detect the thing. My windows laptop won't connect to it either, I've gotta clean out the mess I made trying to get the upgrade to work before I can use it again.


August 5th, 2003, 02:13
I had dstumbler working great on my FreeBSD 5.0 laptop a while ago. I just moved it to 5.1, so I'll put it back together and see if it works. I just built the airtools out of ports and had no problems. I had it working with the built in wireless as well as an prism2 card that I have.

I'll get my laptop all fixed up to 5.1 and let you know how it goes.


August 5th, 2003, 12:25
I'm coming to the conclusion that dstumbler is just flakey. I ended up going to a client on yesterday and never made it back to the office so I didn't get a chance to play yesterday. I poped in my wireless card today and started dhclient on it, fired up dstumbler, and nothing. The card had associated itself with the network and was talking. I played around with wicontrol no luck. Did some work, played around with kdm, actualy got it to work the way I wanted, rebooted a few times to make sure it was working right, and figured hey maybe I'm on a hot streak I'll try dstumbler again. I started it with dstumbler wi0 and it worked, picked up the network right away. Either I actually have some sort of magic touch which I kind of doubt, or something is just barely teetering on the edge of working properly. The only changes I made to the system since I tried it the first time today were to kdmrc, added a script to start kdm in /usr/loca/etc/rc.d, and a slight change to the script that starts inspfan. I don't see how any of that should have effected anything with the network.


September 11th, 2003, 22:57
Tried to get dstumbler working on 5.1, and a no go. Even tried with the BETA version from h1kari. From what I've read it works for some prism2.5 based cards, but won't work for my DWL-650.

Here's the link to the beta version


September 17th, 2003, 17:15
Got airtools working on my 5.1 box.

See here: